Linux OMTC: Previous text isn't cleared before drawing updated version over it (e.g. MemChaser)

RESOLVED DUPLICATE of bug 799644

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 799644
5 years ago
5 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 669654 [details]
screenshot of the problem

I turned on OMTC in a self-built Linux Nightly from today, using the steps in http://mozillagfx.wordpress.com/2012/10/06/how-to-help-testing-off-main-thread-compositing/ (I had layer acceleration on for a while already, and it's looking quite good, so I was happy to step to the next level of testing).

I have MemChaser installed, see https://wiki.mozilla.org/QA/Automation_Services/Projects/Addons/MemChaser - and when looking at its output in the add-ons bar, which updates frequently, I tend to see the updated text being painted over the previous one.

I have also seen this in other places randomly, like the summary input box of this very bug - and I have even seen the same effect on B2G on my otoro (AFAIK we're using OMTC there as well, right?) - but I haven't seen this on Nightly when OMTC is not activated.

Interestingly, it looks a lot to me like the problem only happens in when the window is active - when the focus is on a window of my screen shot tool, for example, or on an unfocused window I have on a secondary screen, the update of the MemChaser info is always drawing correctly and not showing this effect. It also snaps back to being clean when I unfocus the window.

The attached screen shot shows the problem, I very much think that my usage of my own theme (LCARStrek, available from AMO) is not directly connected with the problem, esp. since I'm seeing it randomly even within web content like the mentioned input field here, on B2G, and only with OMTC but not without.

Comment 1

5 years ago
I can see something like that when scrolling in gmail sometimes also.
If you have a chat and an email with ads next to it, and scroll, the ad text above the chat isn't cleared properly.
(Reporter)

Comment 2

5 years ago
Created attachment 672592 [details]
B2G screenshot - browser, top sites

I believe that the intermittent B2G rendering problem I see on my otoro device is the same thing, here also the active pane and fast drawing something new does not do away with the previous content, esp. text, while drawing the new content over it.

Here is an example that I saw when scrolling/panning the top sites list in the browser somewhat fast.
(Reporter)

Comment 3

5 years ago
Created attachment 672598 [details]
B2G screenshot - Contacts

Here's another B2G screenshot, this time from the Contacts app, this happened when I was going back from viewing the details of a contact (don't mind personal details that could be present in the picture, this is my own data and is public on my website anyhow).
(Reporter)

Comment 4

5 years ago
As those graphics glitches happen in B2G as well and look pretty unprofessional, I think this should really be solved for basecamp - even if they go away again when causing graphics invalidation on the display in some way.
blocking-basecamp: --- → ?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799644
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.