Closed Bug 799692 Opened 9 years ago Closed 9 years ago

Add CNNIC EV root certificate to NSS

Categories

(NSS :: CA Certificates Code, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kwilson, Assigned: KaiE)

References

Details

(Whiteboard: test complete)

Attachments

(1 file)

1.43 KB, application/pkix-cert
Details
Attached file CNNIC EV Root Cert
This bug requests inclusion in the NSS root certificate store of the following certificate, owned by CNNIC.

Friendly name: China Internet Network Information Center EV Certificates Root
Certificate location: https://bugzilla.mozilla.org/attachment.cgi?id=486481
SHA1 Fingerprint: 4F:99:AA:93:FB:2B:D1:37:26:A1:99:4A:CE:7F:F0:05:F2:93:5D:1E
Trust flags: Websites
Test URL: https://evdemo.cnnic.cn/

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificates approved for inclusion in bug #607208.

The next steps are as follows:

1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificates have been attached.

2) A Mozilla representative creates a patch with the new certificates, and provides a special test version of Firefox.

3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificates have been correctly imported and that websites work correctly.

4) The Mozilla representative requests that another Mozilla representative review the patch.

5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.

6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
Anyin, Please see step #1 above.
Blocks: 799697
Dear Kathleen,

I confirmed all the data in bug is correct, and the attached certificate is also correct. Thanks.

Regards,
Anyin
Thanks for confirming that the data in this bug is correct.

Root inclusions and changes are usually grouped and done as a batch when there is
either a large enough set of changes or about every 3 months.

At some point in the next 3 months a test build will be provided and this bug
will be updated to request that you test it. Since you are cc'd on this bug,
you will get notification via email when that happens.
Thanks Kathleen's update, now awaiting new test build of FireFox.

Regards,
Anyin
Depends on: 857615
Assignee: nobody → kaie
Please proceed with testing.

Important reminder:
At this phase, we change the NSS root CA list, which covers domain validation.

At this time, please test that your root has been correctly included and 
that trust flags are set correctly, and that connections to your test site work
with basic domain validation status.

If you have requested EV (extended validation), this is NOT yet enabled,
it will be done at a later time, in a separate bug.


The test build is available at
  http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/kaie@kuix.de-cdb68506e138/

Please download a binary for your preferred operating system.

(Only if the above link fails, you may use this backup location:
  https://kuix.de/mozilla/tryserver-roots-20130403/ )

Can a CA representative please verify the trust settings for correctness?

FYI: https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion

(See also the initial comments in this bug.
 You should ensure that you're using a fresh profile,
 to make sure you really see the trust bits provided by this build,
 not trust settings that you had set manually in an application profile.
 To learn how to use a separate profile for testing, refer to
 http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
 or http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows )
I have used the test build and a fresh profile to confirm the new root cert is included with the correct trust bit set. 

A representative of the CA needs to also confirm that they have installed the test build and verified that the correct root is included and the correct trust bit set. https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion
Thanks for your work, I have used the test build and confirmed that all checkpoints done.
I also want to know when the EV-enablement could be done.

Regards,
Wanglei
We tested the new build and confirmed that new root cert is included with the correct trust bit set.

PS: Wanglei(Wanglei@cnnic.cn) is technical engineer from CNNIC CA. 

Regards,
An Yin
(In reply to 王磊 from comment #7)
> I also want to know when the EV-enablement could be done.

That work hasn't yet been scheduled. It will happen sometime after root inclusion, and will be tracked in bug #799697.
Whiteboard: test complete
Target Milestone: --- → 3.15
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.