PostgreSQL 9.2 requires DBD::Pg 2.19.3

RESOLVED FIXED in Bugzilla 4.2

Status

()

Bugzilla
Installation & Upgrading
P1
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: TC.Schmidt, Assigned: Frédéric Buclin)

Tracking

Bugzilla 4.2
Bug Flags:
approval +
approval4.4 +
blocking4.4 +
approval4.2 +
blocking4.2.4 +

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.14 (KHTML, like Gecko) Version/6.0.1 Safari/536.26.14

Steps to reproduce:

Using PostgreSQL 9.2.
Running ./checksetup.pl as "root".


Actual results:

./checksetup.pl reports:

    DBD::Pg::db table_info failed: ERROR:  column t.spclocation does not exist
    LINE 11: ...t(t.spcname) AS "pg_tablespace_name", quote_ident(t.spclocat...
                                                                                           ^ [for Statement "

and more.


Expected results:

The database should have been initialized.
(Reporter)

Updated

5 years ago
Severity: normal → blocker
OS: All → Mac OS X
Priority: -- → P1
Hardware: All → x86_64
(Assignee)

Comment 1

5 years ago
You have a too old version of DBD::Pg. You need at least 2.19.3, see https://rt.cpan.org/Public/Bug/Display.html?id=77042.
Assignee: installation → LpSolit
Severity: blocker → major
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: blocking4.4+
Flags: blocking4.2.4+
OS: Mac OS X → All
Hardware: x86_64 → All
Summary: [PostgreSQL] checksetup.pl reports "ERROR: column t.spclocation does not exist" on PostgreSQL 9.2 → PostgreSQL 9.2 requires DBD::Pg 2.19.3
Target Milestone: --- → Bugzilla 4.2
(Assignee)

Comment 2

5 years ago
Created attachment 669808 [details] [diff] [review]
patch, v1
Attachment #669808 - Flags: review?(dkl)
(Reporter)

Comment 3

5 years ago
Ok. After Updating to DBD::Pg 2.19.3 everything seems to be installed well.
(Assignee)

Updated

5 years ago
Attachment #669808 - Flags: review?(glob)
Comment on attachment 669808 [details] [diff] [review]
patch, v1

r=glob by inspection.
Attachment #669808 - Flags: review?(glob)
Attachment #669808 - Flags: review?(dkl)
Attachment #669808 - Flags: review+
(Assignee)

Updated

5 years ago
Flags: approval4.4+
Flags: approval4.2+
Flags: approval+
(Assignee)

Comment 5

5 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/DB/Pg.pm
Committed revision 8438.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified Bugzilla/DB/Pg.pm
Committed revision 8427.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified Bugzilla/DB/Pg.pm
Committed revision 8154.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.