Closed Bug 799849 Opened 7 years ago Closed 7 years ago

Wrap nothrow libstdc++ operators so that dynamic libraries that use them go through jemalloc when it's enabled

Categories

(Core :: General, defect)

ARM
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: cjones, Assigned: cjones)

References

Details

Attachments

(1 file)

If gecko code loads libraries on bionic platforms that use nothrow operators, then they can end up exchanging pointers to different heaps.  This obviously makes for unhappy/sg:crit.
Assignee: nobody → jones.chris.g
blocking-basecamp: --- → +
Attachment #669878 - Flags: review?(mh+mozilla)
Comment on attachment 669878 [details] [diff] [review]
Wrap nothrow libstdc++ allocators

Review of attachment 669878 [details] [diff] [review]:
-----------------------------------------------------------------

You also need to add them to http://hg.mozilla.org/mozilla-central/file/99898ec9976a/configure.in#l7152
Attachment #669878 - Flags: review?(mh+mozilla) → review+
Duplicate of this bug: 799820
No longer depends on: 766810
https://hg.mozilla.org/mozilla-central/rev/9cabc319f7ff
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Please set the appropriate tracking flags/whiteboard status when landing on aurora.
Whiteboard: [checkin-needed:aurora]
You need to log in before you can comment on or make changes to this bug.