Closed Bug 799948 Opened 10 years ago Closed 10 years ago

[gallery] alternating between portrait and landscape mode leaves artifacts in the toolbar

Categories

(Firefox OS Graveyard :: Gaia, defect, P3)

defect

Tracking

(blocking-basecamp:-)

RESOLVED DUPLICATE of bug 799644
blocking-basecamp -

People

(Reporter: ttaubert, Unassigned)

Details

(Whiteboard: [label:gallery][label:polish])

If you alternate multiple times between portrait and landscape mode you see the camera and the select button twice, like ghost images. Here's an example:

http://i.imgur.com/lQm11.jpg

Sorry for the bad quality of the picture. These buttons are much more visible in real life and will probably really confuse users.

[apps/gallery/style/gallery.css]
footer {
  background: rgba(0, 0, 0, 0.75);
}

Removing the opacity value or setting it to 1 removes these artifacts so I suspect those are rendering/invalidation issues - which we also might be able to work around? I don't see the same issue in the PhotoState.
Requesting blocking because I think this could really confuse users.
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Priority: -- → P3
I recently learned how to create screenshots. Here's a better image of the issue :)

http://i.imgur.com/MHcmu.jpg
FWIW I see the same artifacts in the background of the cards view. This is on a Nexus S so those bugs may not be existent on the Otoro/Unagi devices.
Re-nominating since only reported on a non-shipping device.

Requesting qa-wanted for confirmation on Unagi/Otoro.
blocking-basecamp: + → ?
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799644
Duplicatte -- clearing blocking flag.
blocking-basecamp: ? → -
remove qawanted also
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.