create bouncer entries for nightly and aurora stub installers

RESOLVED FIXED

Status

Release Engineering
General Automation
P3
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bouncer])

(Reporter)

Description

5 years ago
I'm a bit confused about how bug 731299 is useful given that metrics doesn't think having them in bouncer is useful, but I suspect I'm just missing something here. Given that, sounds like we need to go ahead and put both stub on full installers for Nightly and Aurora in bouncer.

On 10/10/12 01:52 PM, Alex Keybl wrote:> The other reason to do this is because marketing requested it in 731299 – Create bouncer links for Aurora downloads to be able to track their campaigns. If we're at the point in the process where we just need to change RelEng documentation on release days, I'd prefer that (even though this isn't a requirement for stub installer).
> 
> -Alex
>  
> On Oct 10, 2012, at 10:22 AM, Chris More <cmore@mozilla.com> wrote:
> 
>> It is be helpful to keep the buttons consistent as we move pages from the legacy PHP site (going away) to the new Python-based Bedrock site. We already have the logic in the bedrock download buttons and it would be nice to add Aurora and Nightly in too. The way that it is set up now is that all we have to do is place a button instance on a template, say what channels, and all the other logic is included. We will still need to make sure that product-details is up to date.
>>
>> ----- Original Message -----
>> From: "Ben Hearsum" <bhearsum@mozilla.com>
>> To: "Chris More" <cmore@mozilla.com>
>> Cc: "Alex Keybl" <akeybl@mozilla.com>, "Jeff Gilbert" <jgilbert@mozilla.com>, "Laura Thomson" <lthomson@mozilla.com>
>> Sent: Wednesday, October 10, 2012 10:19:01 AM
>> Subject: Re: question from bhearsum
>>
>> Sorry. I was trying to gauge how important it was for the download
>> buttons to be consistent (eg, all point at d.m.o). Updating these
>> bouncer locations is error-prone manual work every 6 weeks for RelEng,
>> and unless there's a good reason that we need them, I'd rather not
>> maintain them.
>>
(Reporter)

Updated

5 years ago
Blocks: 794639
(In reply to Ben Hearsum [:bhearsum] from comment #0)
> I'm a bit confused about how bug 731299 is useful given that metrics doesn't
> think having them in bouncer is useful, but I suspect I'm just missing
> something here. Given that, sounds like we need to go ahead and put both
> stub on full installers for Nightly and Aurora in bouncer.

Anurag: can you help clarify what is/isnt needed?
(Reporter)

Comment 2

5 years ago
(In reply to John O'Duinn [:joduinn] from comment #1)
> (In reply to Ben Hearsum [:bhearsum] from comment #0)
> > I'm a bit confused about how bug 731299 is useful given that metrics doesn't
> > think having them in bouncer is useful, but I suspect I'm just missing
> > something here. Given that, sounds like we need to go ahead and put both
> > stub on full installers for Nightly and Aurora in bouncer.
> 
> Anurag: can you help clarify what is/isnt needed?

John, these are wanted for WebDev/Marketing reasons - not Metrics ones. Cmore or Alex might be able to clarify better.

Comment 3

5 years ago
Having nighty and aurora will be helpful and will make our lives easier on mozilla.org since we can standardize all channel buttons to consistent logic. This will help reduce regressions and make QA easier.
(Reporter)

Comment 4

5 years ago
I created a firefox-aurora-stub product + location, set to be SSL only: https://download.mozilla.org/?product=firefox-aurora-stub&os=win&lang=en-US

This will 404 until stub installer lands on Aurora.

I'm told Nightly isn't a blocker so I didn't create it.

Updated

5 years ago
Priority: -- → P3
Whiteboard: [bouncer]
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Comment 5

3 years ago
I think we decided we don't need bouncer entries for nightly stub...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.