[Home] Double screens adding website bookmarks to home screen

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User has to click the 'Add to home screen' button twice when adding a website bookmark to the home screen.

1) Open browser > Go to any website
2) Click star button > Select 'Add bookmark to home screen'
3) Click Add button on page with bookmark details

expected: bookmark added to home screen
actual: Add screen reappears- bookmark is added after second submission
(Reporter)

Updated

5 years ago
OS: Mac OS X → Gonk
Hardware: x86 → ARM
can reproduce it which use below html/js:
https://gist.github.com/3877117
This bug is related to Bug 795782, this bug is about re-fire message when app restart. 

when add a link to home will cause homescreen crash and browser use message to open the "add to homescreen" dialog, so the dialog show twice.

1. browser use MozActivity (gecko send the message) to Open "add a link" dialog in homescreen app
2. homescreen crashed and restart here
3. the MozActivity message fire again
4. the dialog show again.

this bug is disappear when Bug 795782 fixed, but there is another bug about homescreen crash.
See Also: → bug 795782
Depends on: 795782
(In reply to Yuren Ju [:yurenju] from comment #2)
> this bug is disappear when Bug 795782 fixed, but there is another bug about
> homescreen crash.

May I ask what the STR is to reproduce the new bug? Glad to support this issue if it's related to the System Message mechanism. :)
Sure, it's my pleasure.

STR:

1. open browser and go to any website (e.g. http://twitter.com/)
2. click right lower right corner star button
3. click "Add to Home Screen" button
4. Click "Add to Home Screen" when dialog appeared. 

excepted:
Home screen show immediate, and app icon added on one of the pages in home screen.

actual:
first second, home screen looks good. but in next second, home screen looks like been restarted. (the bottom panel icons disappear and show again.) but website already added into home screen.
(In reply to Yuren Ju [:yurenju] from comment #4)
> Sure, it's my pleasure.
> 
> STR:
> 
> 1. open browser and go to any website (e.g. http://twitter.com/)
> 2. click right lower right corner star button
> 3. click "Add to Home Screen" button
> 4. Click "Add to Home Screen" when dialog appeared. 
> 
> excepted:
> Home screen show immediate, and app icon added on one of the pages in home
> screen.
> 
> actual:
> first second, home screen looks good. but in next second, home screen looks
> like been restarted. (the bottom panel icons disappear and show again.) but
> website already added into home screen.

Hi Yuren,

I think we don't really have bug here because this is actually a normal OOM behavior. Our Homescreen app can also have chances to be killed at any time when running out of memory. What do you think?
Agree, double click issue was fixed and bookmark function is worked. close this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Verified able to add bookmarks to the Home screen without double screens on the 11/28 unagi build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.