B2G STKUI: Add support to STK_CMD_SET_UP_IDLE_MODE_TEXT

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: frsela, Assigned: frsela)

Tracking

unspecified
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

Add support to STK_CMD_SET_UP_IDLE_MODE_TEXT on STK app.
Blocks: 801269
blocking-basecamp: --- → ?
Blocks: 800269
As Yoshi informed me:

SET_UP_IDLE_MODE_TEXT is to show the text in idle mode (i.e. screen off),
whereas REFRESH is to tell ME to remove the idle mode text()
I'd been talking with Rafael and we decided to show this messages with the attention screen (notifications) and ignore REFRESH command to remove it since it'll be removed automatically when the users attends the message.
Duplicate of this bug: 800269
(In reply to Fernando R. Sela from comment #2)
> I'd been talking with Rafael and we decided to show this messages with the
> attention screen (notifications) and ignore REFRESH command to remove it
> since it'll be removed automatically when the users attends the message.

To clarify, REFRESH won't be ignored, I talked with Beatriz and we shall follow the specs so we should remove the notification message.
Created attachment 671809 [details] [diff] [review]
Patch to support IDLE messages commands

This is a preview since this patch is asking the user to ALLOW the notification and shall be transparent to him.

Also it's needed to add a remove method but I'm not sure if remove is supported by mozNotification ...
Attachment #671809 - Flags: feedback?(21)
Assignee: nobody → frsela
Comment on attachment 671809 [details] [diff] [review]
Patch to support IDLE messages commands

The issue with permissions had been solved in my handset, I think this patch is prepared to land.

The message remove is pending (TODO)

----

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #671809 - Flags: feedback?(21) → review?(21)
Per b2g-drivers, no feature work will be marked as blocking, and require driver approval to land.  Marking as blocking-, please get approval from Vivien before landing.
blocking-basecamp: ? → -
Blocks: 802677
Depends on: 782211

Comment 8

5 years ago
Fernando, Please explain why this would depend on 782211.  Removing for now.
No longer depends on: 782211
(In reply to Doug Turner (:dougt) from comment #8)
> Fernando, Please explain why this would depend on 782211.  Removing for now.

We need the improvements on 782211 in order to be able to remove notifications when the REFRESH command is sent by the UICC.

But after the discussion in the webapi list this won't be landed before V1 so I agree to remove this dependency.
Comment on attachment 671809 [details] [diff] [review]
Patch to support IDLE messages commands

Hi Vivien,

It's pending the remove notification on REFRESH command but I think we cann't support it now since mozNotification API don't support it ... probably in next release we can support this one.

Now is commented as TO-DO.  In order to avoid "noise" changing the patch for only this comment I ask you for approval to land it and I'll rebase it and also change this comment to a more clear one before the final land :p

--


NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #671809 - Flags: approval-gaia-master?(21)
Comment on attachment 671809 [details] [diff] [review]
Patch to support IDLE messages commands

Review of attachment 671809 [details] [diff] [review]:
-----------------------------------------------------------------

Part of of a late feature work. This code only alters the behavior of the icc part of settings with small changes. a=me.
Attachment #671809 - Flags: review?(21)
Attachment #671809 - Flags: review+
Attachment #671809 - Flags: approval-gaia-master?(21)
Attachment #671809 - Flags: approval-gaia-master+
(In reply to Doug Turner (:dougt) from comment #8)
> Fernando, Please explain why this would depend on 782211.  Removing for now.

I believe this is because they want to use notification.close.
Created attachment 673816 [details]
Link to GitHub PR

Patch approved. PR link
Created attachment 673818 [details]
Link to GitHub PR
Attachment #673816 - Attachment is obsolete: true
Merged: https://github.com/mozilla-b2g/gaia/pull/5928
https://github.com/mozilla-b2g/gaia/commit/b98fb062612ee58fefdeebc27c0d42c3751dcaf2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Created attachment 673835 [details] [diff] [review]
Syntax error fix

A little syntax fix

--

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #673835 - Flags: approval-gaia-master?(21)
Attachment #673835 - Flags: approval-gaia-master?(21) → approval-gaia-master+

Comment 17

5 years ago
fix verified in Build 20130113070202 - the text in shown when in idle mode
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.