Closed Bug 800286 Opened 10 years ago Closed 10 years ago

Going to youtube.com affects the state of the back and forward buttons

Categories

(Firefox for Android Graveyard :: General, defect)

17 Branch
ARM
Android
defect
Not set
major

Tracking

(firefox16 wontfix, firefox17 wontfix, firefox18 wontfix, firefox19 wontfix, firefox20 wontfix, firefox21 affected, firefox22 affected, firefox23 affected, fennec+)

RESOLVED WORKSFORME
Tracking Status
firefox16 --- wontfix
firefox17 --- wontfix
firefox18 --- wontfix
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- affected
firefox22 --- affected
firefox23 --- affected
fennec + ---

People

(Reporter: AdrianT, Assigned: wesj)

References

()

Details

Attachments

(1 file)

Attached file logs
Firefox Mobile 17.0b1
Device: Samsung Galaxy Tab 2 7.0 (Android 4.0.4)

Steps to reproduce:
1. Load any link - for e.g. news.google.com.
2. In the same tab load youtube.com
3. Search for a video and open the video details page.
4. Go back to the possible video lists and then back to the youtube main page.
5. Try to go forward to the search again.
6. Go back to the first page in the tab history and then forward until the the forward button is greyed out - you have reached the last page in the tab history.

Expected results:
The user can use back and forward any time the action is valid. The buttons are greyed when the action is not possible.

Actual results:
When navigating back through the youtube pages the forward button remains grey until the user navigates back to a different page then youtube - in this case news.google.com. Once the user has reached a page other then youtube the forward button does not become grey any more even if there aren't any other pages in the tab history.

Notes:
Please see the video capture: http://youtu.be/q1OzZl4NZP0
Do you still see this on latest code?
Flags: needinfo?(adrian.tamas)
This is still an issue on Nightly 22.0a1 2013-03-24 on the Samsung Galaxy Tab (Android 4.0.4). There are still instances where the Forward button remains grayed even if it should be hidden, where the user can tap the Forward button and nothing happens because there is no page to go to. Please see the videocapture: http://youtu.be/7UEFs9C6vqU
Flags: needinfo?(adrian.tamas)
tracking-fennec: --- → ?
I wonder if this pushState related? Wes? Is this a dupe?
Assignee: nobody → wjohnston
tracking-fennec: ? → +
I can't reproduce this. Maybe was fixed by bug 815715.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.