Closed Bug 800429 Opened 10 years ago Closed 10 years ago

Stop trying to test __init__.py

Categories

(Release Engineering :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: catlee, Assigned: catlee)

References

Details

(Whiteboard: [testing])

Attachments

(1 file)

Preproduction is failing tests partly because it tries to test __init__.py, which trial doesn't like
Blocks: 800430
We probably don't need this file. I removed it in http://hg.mozilla.org/build/buildbotcustom/rev/2c123694196d
Assignee: nobody → catlee
And backed out because we need buildbotcustom.test.utils to be importable.
It turns out we don't need most of the code in utils.py. I moved the relevant code into test_hgpoller.py and removed __init__.py and utils.py. This should also fix some other test failures because we're trying to test old code in utils.py
Attachment #670499 - Flags: review?(bhearsum)
Priority: -- → P5
Whiteboard: [testing]
Attachment #670499 - Flags: review?(bhearsum) → review+
Attachment #670499 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.