Double-counting nsAttrValues

RESOLVED DUPLICATE of bug 1026985

Status

()

RESOLVED DUPLICATE of bug 1026985
6 years ago
4 years ago

People

(Reporter: njn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 670664 [details]
partial DMD output

The attached file shows part of DMD's output, more than enough to demonstrate the problem.

Are nsAttrValues shared in some way?
Inline style ones are, after bug 760331.
We're probably double counting shared MiscContainers.
The obvious fix here is not to count MiscContainers of type eCSSStyleRule from nsAttrValue::SizeOfWhatever, but to count them from the hashtable in nsHTMLCSSStyleSheet instead.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026985
You need to log in before you can comment on or make changes to this bug.