Last Comment Bug 800703 - Rename the existing, Valgrind-based DMD as "DMDV"
: Rename the existing, Valgrind-based DMD as "DMDV"
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 22:20 PDT by Nicholas Nethercote [:njn]
Modified: 2012-12-15 19:00 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Rename the existing, Valgrind-based DMD as "DMDV". (85.96 KB, patch)
2012-10-11 22:21 PDT, Nicholas Nethercote [:njn]
khuey: review+
justin.lebar+bug: approval‑mozilla‑b2g18+
Details | Diff | Review

Description Nicholas Nethercote [:njn] 2012-10-11 22:20:54 PDT
I have a version of DMD that doesn't require Valgrind in the works (bug
717853).  My plan is for it to eventually obsolete the Valgrind-based one.
However, there will be a period of overlap where both tools are in use.  So
the point of this bug is to rename the Valgrind-based DMD as "DMDV".
Comment 1 Nicholas Nethercote [:njn] 2012-10-11 22:21:09 PDT
Created attachment 670692 [details] [diff] [review]
Rename the existing, Valgrind-based DMD as "DMDV".

This patch renames DMD as DMDV.  Non-trivial aspects:

- It adds a new directory, tools/dmdv.  Careful checking of the Makefile.in
  and toolkit/* changes will be appreciated.

- It moves the existing dmd.h file from xpcom/base/ to tools/dmdv/dmdv.h, a
  much better place for it.  It also removes some trailing whitespace from
  that file.

- It adds tools/dmdv/dmdv.patch, which is the patch from bug 676724.
  Because I'm not planning to develop DMDV further, having it as a patch in
  the tree seems pretty reasonable.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-10-12 10:35:33 PDT
Comment on attachment 670692 [details] [diff] [review]
Rename the existing, Valgrind-based DMD as "DMDV".

Review of attachment 670692 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't look at this too closely, just assumed you knew what you were doing.
Comment 3 Nicholas Nethercote [:njn] 2012-10-12 13:42:13 PDT
You mean you didn't read dmdv.patch line by line?  I'm shocked :P

More seriously, hopefully you looked at the Makfile.in and toolkit/* changes at least a little bit.
Comment 4 Nicholas Nethercote [:njn] 2012-10-14 16:42:30 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1949f7d5c6ed
Comment 5 Ed Morley [:emorley] 2012-10-16 01:29:57 PDT
https://hg.mozilla.org/mozilla-central/rev/1949f7d5c6ed
Comment 6 Justin Lebar (not reading bugmail) 2012-12-13 22:37:09 PST
Comment on attachment 670692 [details] [diff] [review]
Rename the existing, Valgrind-based DMD as "DMDV".

[Triage Comment]
Needed for bug 717853, npotb, and anyway just a renaming.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-12-15 19:00:06 PST
https://hg.mozilla.org/releases/mozilla-b2g18/rev/d1cbbf7a3eca

Note You need to log in before you can comment on or make changes to this bug.