Last Comment Bug 801224 - redirect to second captcha page never loads
: redirect to second captcha page never loads
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 17 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jet Villegas (:jet)
: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
:
Mentors:
http://www.lhj.com/lhj/file.jsp?item=...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 20:07 PDT by starletpunk1297
Modified: 2012-10-18 10:59 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
fixed
unaffected
unaffected


Attachments

Description starletpunk1297 2012-10-12 20:07:09 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

attempted to enter a sweepstakes with the new beta 17.0 version of firefox. there is a button to click to make another window open for the captcha entry page. the page opens but the captcha entry never loads. this only happens in this beta version.


Actual results:

second window opened but did not load captcha information


Expected results:

the second window should open and then the captcha should load, as it does in the 16 version
Comment 1 Matthias Versen [:Matti] 2012-10-13 08:12:04 PDT
The URL and the exact steps to reproduce are necessary.
Comment 2 starletpunk1297 2012-10-14 20:23:27 PDT
The problem persists in safe mode with addons disabled.
Comment 3 Loic 2012-10-16 09:04:26 PDT
Where is the link to open a captcha in a 2nd window?

Please, provide clear STR to save our time.
Comment 4 Matthias Versen [:Matti] 2012-10-16 18:43:30 PDT
STR:
1) load the given URL
2) click on "login" at the top right
3) use "testcc@mailinator.com" and "123456" to login
4) load the given URL again
5) click on the big "enter" under "walmart"
6) click the "submit" button
7) a CSS "popup" with a captcha should open but it's empty.

I can confirm the issue with Firefox and that it's working in Firefox16.0.1
Comment 5 Loic 2012-10-17 03:41:13 PDT
Matthias, thanks for the STR.
But it's only broken in FF17, it works fine in FF18+ (see http://i.imgur.com/6NQSz.jpg), so I guess the regression is already fixed and this bug is a dupe.


good=2012-07-25
bad=2012-07-26
Changelog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ef20925bc2a5&tochange=20db7c6d82cc
Comment 6 Matthias Versen [:Matti] 2012-10-17 10:03:06 PDT
Sorry that I forgot to mention that it's already fixed on trunk.
I had no time to dig deeper in this issue, thanks for doing the regression search.
We are at beta1 at the moment ?
There is a good chance that the fix will be in beta2.
Comment 7 Loic 2012-10-17 10:11:05 PDT
Yes, only 17b1 at the moment.
Comment 8 Alex Keybl [:akeybl] 2012-10-17 16:01:05 PDT
It would be helpful to find a smaller regression range and/or when this was fixed. Anthony - can you help with that?

Jet - I think this bug is in your wheelhouse. Let me know if I'm wrong. Also CC'ing roc just in case.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 16:11:27 PDT
CSS pop-up content shows in 17.0b2 and does not in 17.0b1. I'm guessing something was uplifted that fixed this.

Pushlog between 17b1 and 17b2:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=6b83222781e3&tochange=2ba4becf6e35
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 16:27:20 PDT
Using the tinderbox builds I think the regression range is between the following changesets.

Last Bad:
http://hg.mozilla.org/releases/mozilla-beta/rev/7ab34cfe4869

First Good:
http://hg.mozilla.org/releases/mozilla-beta/rev/e669a7b1ed5e

Pushlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=7ab34cfe4869&tochange=e669a7b1ed5e

Suspected fixed by bug 786740 - Fix invalidations on out-of-flow frames (roc,r=cwiiis,a=lsblakk)
Comment 11 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-17 16:41:19 PDT
So it's fixed on 17 now. We can close this bug, then?
Comment 12 Loic 2012-10-17 16:44:55 PDT
Yes, it's a dupe of bug 786740.
Comment 13 starletpunk1297 2012-10-17 17:29:37 PDT
Okay.  So, if the fix is in 17b2, how can I get a copy of it?
Comment 14 Matthias Versen [:Matti] 2012-10-17 19:21:53 PDT
(In reply to starletpunk1297 from comment #13)
> Okay.  So, if the fix is in 17b2, how can I get a copy of it?

I don't know the exact release date for beta2 but it should be soon, Your beta1 build will update to beta2 and the issue should be gone.
Comment 15 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-18 10:59:00 PDT
Our current plan is to release Firefox 17.0b2 on Monday, October 22nd. If you simply want to test that this is fixed, you can grab the candidate build from here:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/17.0b2-candidates/build1/

Note You need to log in before you can comment on or make changes to this bug.