Trying to pave-over install Firefox while Firefox is already running always leaves behind a to_be_deleted folder

RESOLVED INVALID

Status

()

Firefox
Installer
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps:

1. Install firefox with the stub installer and launch it
2. Install firefox again with the stub install while firefox is already running

Expected:

A prompt should appear indicating that firefox is already running. Upon closing it, if I launch firefox, then I should get the latest bits from the install I just did. There should be no to_be_deleted folder left behind in the installation directory.

Actual:

The to_be_deleted folder gets left behind after completing the installation (prompt dismissed and firefox launched).
(Reporter)

Comment 1

6 years ago
Confirmed on Vista, XP, and Win 7 btw. This is regression also.
Blocks: 322206
Keywords: regression
There is no way to delete files in use on Windows without restarting the OS. The files in the directory and the directory itself will be deleted on OS restart.

We do this with the stub instead of asking the user to restart the OS and it isn't a regression since this is behavior we wanted.

Also, see bug 797157 comment #24
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: regression
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.