All users were logged out of Bugzilla on October 13th, 2018

Markup Pane and Style Rule View would not disappear

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 months ago

People

(Reporter: alice0775, Assigned: dcamp)

Tracking

17 Branch
x86
Windows 7

Firefox Tracking Flags

(firefox16 unaffected, firefox17- wontfix, firefox18- affected, firefox19- affected, firefox20 fixed)

Details

(Whiteboard: [check-if-fixed-because-toolbox])

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-beta/rev/6b83222781e3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20121010150351


Steps to reproduce:
  1. Open https://developer.mozilla.org/en-US/docs/CSS/Writing_Efficient_CSS?redirectlocale=ja&redirectslug=Writing_Efficient_CSS#Tag_Rules
  2. Scroll to "treeitem > treerow {…} /* A tag-based rule */"
  3. Double click "treeitem"

  4. Right click on highlight and choose "Inspect Element(Q)
  5. Open Markup Panel 
  5. Open Style Rule View

  6. Click "x" button at the right side of inspector-toolbar
     --- observe Markup Pane and Style Rule View

  7. Click NewTab button on the Tab bar
     ---  observe Markup Pane and Style Rule View

Actual results:
  Markup Pane and Style Rule View would not disappear

Expected reults:
  Markup Pane and Style Rule View should disappear
(Reporter)

Comment 1

6 years ago
There are too many devtools related error... 

Error: TypeError: this._containers.get(...).editor is undefined
Source file: resource:///modules/devtools/MarkupView.jsm
Line: 349

Error: TypeError: domRules is null
Source file: resource:///modules/devtools/CssRuleView.jsm
Line: 165

Error: TypeError: this._elementStyle is null
Source file: resource:///modules/devtools/CssRuleView.jsm
Line: 978

Error: TypeError: aContext is null
Source file: resource:///modules/devtools/StyleInspector.jsm
Line: 46

Error: TypeError: this._elementStyle is null
Source file: resource:///modules/devtools/CssRuleView.jsm
Line: 978


Please debug devtools. :(
(Reporter)

Updated

6 years ago
Blocks: 777085
(Reporter)

Updated

6 years ago
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
This isn't in all cases of calling up that view, so not something we'd respin for and since it's affecting that view in only certain cases I think that only a smallish subset of users will hit this, so not tracking for 17. But we should try to get a fix on this for 18 since it is indeed annoying and your only option when it gets stuck on is to restart the browser.
Assignee: nobody → dcamp
status-firefox16: --- → unaffected
status-firefox17: --- → wontfix
status-firefox18: --- → affected
status-firefox19: --- → affected
tracking-firefox17: ? → +
tracking-firefox18: ? → +
tracking-firefox19: ? → +

Updated

6 years ago
Whiteboard: [check-if-fixed-because-toolbox]

Comment 3

6 years ago
Fixed by the new selection mechanism.

Bug triage, filter on PINKISBEAUTIFUL
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 4

6 years ago
This is an issue that's shipped, and hasn't been called out as a major user issue. No need to track for release.
status-firefox20: --- → fixed
tracking-firefox17: + → -
tracking-firefox18: + → -
tracking-firefox19: + → -

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.