Closed Bug 801477 Opened 7 years ago Closed 7 years ago

Regression: Black flash on startup

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox18 --- verified

People

(Reporter: aaronmt, Assigned: lucasr)

References

Details

(Keywords: regression)

Attachments

(1 file)

It looks like bug 770047 has returned with a quick black screen flash on cold startup, at least for me on my Galaxy Nexus (Android 4.1.1) and Nexus 7 (Android 4.1.2).

--
Tested via Nightly (10/14)
FYI: this is probably caused by http://hg.mozilla.org/mozilla-central/rev/2e416d28e933

Need to find a way to avoid the black flash when SurfaceView is first added to the layout.
Assignee: nobody → lucasr.at.mozilla
Blocks: 767980
Duplicate of this bug: 802281
Attachment #672355 - Flags: review?(bugmail.mozilla)
Comment on attachment 672355 [details] [diff] [review]
Fix black flash on startup caused by SurfaceView

Review of attachment 672355 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks for fixing this, it was really annoying! :)
Attachment #672355 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/414f6660e118
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
No black screen flash on cold startup, marking as verified fixed.

Build: Firefox for Android 19.0a1 (2012-10-30), Firefox for Android 18.0a2 (2012-10-30)
Device: Samsung Galaxy Nexus
OS: Android 4.1.2
Status: RESOLVED → VERIFIED
Comment on attachment 672355 [details] [diff] [review]
Fix black flash on startup caused by SurfaceView

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 767980
User impact if declined: Black flash on startup.
Testing completed (on m-c, etc.): A few weeks in m-c, no issues.
Risk to taking this patch (and alternatives if risky): Small change, that has been in m-c for a few weeks now.
String or UUID changes made by this patch: none
Attachment #672355 - Flags: approval-mozilla-aurora?
Comment on attachment 672355 [details] [diff] [review]
Fix black flash on startup caused by SurfaceView

As discussed offline with Lucas and Release Management team, we will have the entire tab UX improvements ride the trains.
Attachment #672355 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.