Some Hebrew presentation form does not display on Window

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Frank Tang, Assigned: smontagu)

Tracking

Trunk
x86
Windows 95
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
 
(Reporter)

Comment 1

17 years ago
Created attachment 33994 [details] [diff] [review]
split from bug 80130
(Reporter)

Comment 2

17 years ago
this one is depend on 80161 and 80162. But I think the approach is wrong. I 
don't want to put any non ascii value into this transliterate.properties

simon- can you 
1. provide test case to the problem, att attach it in the attachment
2 [details] [diff] [review]. explain the expect result
2. explain the actual result

I think the problem is there, but the coding approach is wrong.
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Depends on: 80161, 80162
(Assignee)

Comment 3

17 years ago
We added this in response to a newsgroup post from Mark David 
mhd@world.std.com, saying:

All of the Windows fonts, including Arial, are missing at least two 
presentation forms which could be used for Yiddish.  Most are missing just 
these two.

FB1F HEBREW LIGATURE YIDDISH YOD YOD PATAH
This is the compatibility character for MacOS Hebrew, so it's very unfortunate 
that this is missing.  When mail is sent from a MacOS client, even though it 
may be translated into this Unicode character, the glyph is missing.  The glyph 
is present in all/most MacOS Hebrew fonts.

FB1D HEBREW LETTER YOD WITH HIRIQ
This combination is new in Unicode 3.0, but it's been in the pipeline for many 
years, and has been official for about two years.
(Assignee)

Comment 4

17 years ago
Created attachment 34536 [details]
testcase
(Reporter)

Comment 5

17 years ago
how important is this?
I think the approach is not good. We need a better approach to solve this 
problem. How important is this bug? If not that important for now, can we mark it 
as future?
Assignee: ftang → simon
Status: ASSIGNED → NEW
(Assignee)

Comment 6

17 years ago
cc-ing arthur.barrett@march-hare.com for feedback on the importance of this bug,
since the impact is mostly in Yiddish and I'm not familiar with Yiddish web
resources.

Even if the specific cases we handle here are relatively marginal, there are
literally thousands of characters in the Unicode data base with non-ASCII values
in the Character Decomposition field. Why don't we open an RFE to provide a new
mechanism to handle those characters (which can probably be futured) and close
this (and related) bugs.

Comment 7

17 years ago
Changing QA contact to giladehven@hotmail.com and copying mahar@eg.ibm.com
QA Contact: andreasb → giladehven
(Reporter)

Comment 8

17 years ago
Change the summary from "change gfx/src/windows/nsFontMetricsWin.cpp for bidi" to 
"Some Hebrew presentation form does not display on Window"
Change component to "Bidi/Hewbrew&Arabic"
Component: Internationalization → BiDi Hebrew & Arabic
Summary: change gfx/src/windows/nsFontMetricsWin.cpp for bidi → Some Hebrew presentation form does not display on Window

Comment 9

17 years ago
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: giladehven → zach
(Reporter)

Updated

17 years ago
Blocks: 115714
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Blocks: 80130
(Assignee)

Comment 10

16 years ago
Created attachment 94525 [details]
Corrected testcase
Attachment #34536 - Attachment is obsolete: true

Comment 11

15 years ago
mahar@eg.ibm.com is no longer in Arabic bugs, so I have removed her from the CC 
list and added myself instead ahtaha@eg.ibm.com. This comment is to inform you 
of this new status. Thank you.

Comment 12

13 years ago
These presentational forms are available with Narkisim, David and Times New
Roman fonts on Windows XP. Perhaps we shouls mark this as WONTFIX and suggest
that people update their fonts and/or version of Windows?
Win95 is no longer supported, gfx/windows is dead, and this WFM with a trunk build on a standard Win XP machine. Closing as WORKSFORME, please re-open if you think there's still something to be fixed here.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.