Closed Bug 801511 Opened 7 years ago Closed 5 years ago

"ASSERTION: Successful load with no container?"

Categories

(Core :: ImageLib, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: jdm)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: Successful load with no container?: 'imageContainer', file layout/generic/nsImageFrame.cpp, line 670

###!!! ASSERTION: null image: 'aImage', file layout/generic/nsImageFrame.cpp, line 291

I'm guessing this is a regression from bug 505385.
Attached file stacks
Ok, so previously the status passed into EmulateRequestFinished was sent through to the OnStopDecode notification (which occurred at load end, etc.) My changes made that status be dropped on the floor; it looks like we need to do something akin to RecordStopRequest that sets the error bit on the image state if the status isn't a success code.
Assignee: nobody → josh
Depends on: 847084
Doesn't assert any longer.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.