The default bug view has changed. See this FAQ.

nsJSIID::HasInstance shouldn't assume that any WebIDL binding object that's nsISupports has classinfo

RESOLVED FIXED in Firefox 17

Status

()

Core
XPConnect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

unspecified
mozilla19
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox17+ fixed, firefox18+ fixed, firefox19+ fixed)

Details

Attachments

(1 attachment)

Because it just ain't true.
Created attachment 671484 [details] [diff] [review]
WebIDL binding objects may not have classinfo even if they're nsISupports.
Attachment #671484 - Flags: review?(peterv)
I think we need this on branches, in general....
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
Attachment #671484 - Flags: review?(peterv) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/95be4274988c
Flags: in-testsuite?
Whiteboard: [need review]
Target Milestone: --- → mozilla19
Comment on attachment 671484 [details] [diff] [review]
WebIDL binding objects may not have classinfo even if they're nsISupports.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial WebIDL bindings landing
User impact if declined: Null-deref crashes that content can trigger
Testing completed (on m-c, etc.): Passes tests and all that.
Risk to taking this patch (and alternatives if risky): Low risk: just a null-check
String or UUID changes made by this patch: None
Attachment #671484 - Flags: approval-mozilla-beta?
Attachment #671484 - Flags: approval-mozilla-aurora?
tracking-firefox17: ? → +
tracking-firefox18: ? → +
tracking-firefox19: ? → +
https://hg.mozilla.org/mozilla-central/rev/95be4274988c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox19: --- → fixed
Resolution: --- → FIXED
Attachment #671484 - Flags: approval-mozilla-beta?
Attachment #671484 - Flags: approval-mozilla-beta+
Attachment #671484 - Flags: approval-mozilla-aurora?
Attachment #671484 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/58ba9dc8ea5a
https://hg.mozilla.org/releases/mozilla-beta/rev/e581c5d6a288
status-firefox17: --- → fixed
status-firefox18: --- → fixed
You need to log in before you can comment on or make changes to this bug.