Display the image in Firefox, normally

RESOLVED DUPLICATE of bug 185618

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 185618
6 years ago
4 years ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Hello,

I have Firefox on Windows Vista. I visit a Web page which is supposed to show me an image, but there is a problem with the fancy viewing presentation of the Web site, so I don't see the image. No problemo, there is a "Download" link. I click it, normally. It directs my Firefox to an image address, ending with ".jpg". Fine.

Actual behaviour :

Because of some server indication, Firefox asks me whether I want to download the file and where I want to save it. It is a choice between downloading and nothing. There is no simple "View in Firefox" choice. I don't want to save the file.

Expected behaviour :

Firefox receives the server indication, but Firefox knows that Firefox is able to display JPEG images. Firefox displays the image normally, in the active tab. This is what I want.

Thank you for improving that, and keep up the good work !

Nicolas

Comment 1

6 years ago
The workaround is to install https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
(Reporter)

Comment 2

6 years ago
I think that request bug 801786 is not a duplicate of request bug 453455.

Request bug 453455 is about making Firefox remember the user choice in case of an "attachment" header sent by the server.

In request bug 801786, I explain that the choice I want is missing. So this request is not about remembering the user choice, it is about offering to the user the choice which is currently missing.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

6 years ago
Sorry I should have asked you to reply with all the "Response Headers" from the server when you turn on the Web Console (Ctrl Shift K) then click the "download" link and click the "HTTP/1.1 200 OK" to bring up the dialog for that JPEG.

Updated

6 years ago
Flags: needinfo?(nicolas.barbulesco)
Mardeg: 
I'm pretty sure that this is a content-disposition:attachment header as you already guessed.
The problem here is not that the reporter wants to permanently assign a helper application (bug 453455), he wants to assign it to firefox and that's not possible.
Your posted addon should fix that.

Comment 5

6 years ago
If the content-type response header is unknown and there isn't an attachment header, this is a duplicate of bug 57342 and the extension workaround is https://addons.mozilla.org/en-US/firefox/addon/open-in-browser/
(Reporter)

Comment 6

6 years ago
(In reply to Mardeg from comment #5)

> If the content-type response header is unknown and there isn't an attachment
> header, this is a duplicate of bug 57342 and the extension workaround is
> https://addons.mozilla.org/en-US/firefox/addon/open-in-browser/

But this is far from being the only case. In what I encounter, the server certainly sends an "attachment" header and an "image/jpeg" MIME type.

This problem is frequently encountered with PDF documents, that the server "forces" the user to download, even though the user's browser is able to display PDF documents.

Because of the "attachment" header, Firefox suggests that the user download the file, and this is good. But the user should be able to choose to view the file in Firefox. If the user chooses so, Firefox should display the file normally, and in this case if Firefox really cannot display the file then Firefox should show the source.
Flags: needinfo?(nicolas.barbulesco)

Comment 7

6 years ago
(In reply to Nicolas Barbulesco from comment #6)
> the user should be able to choose to view
> the file in Firefox. If the user chooses so, Firefox should display the file
> normally
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 185618
(Reporter)

Comment 8

6 years ago
I encounter the same problem for viewing some PDF documents, in Firefox 16.0.2 Linux.
(Reporter)

Updated

5 years ago
Blocks: 86194

Updated

5 years ago
No longer blocks: 86194
(Reporter)

Comment 9

4 years ago
See also :

Bug 773942, for PDF docs
You need to log in before you can comment on or make changes to this bug.