Include app name in crash reporter dialog title if the crash was caused by an app

RESOLVED DUPLICATE of bug 801925

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 801925
6 years ago
6 years ago

People

(Reporter: lco, Assigned: Margaret)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
See pg. 5 of the spec (URL linked) for the spec.

The first time a crash occurs, display the App Crash Reporting prompt if the crash is an app-level crash:

1. The app crash prompt is displayed at the time of the crash (or after, if during isn't feasible).
2. Hitting "Send" when the "Always send a report" pref is ON sends the report for the current crash, and continues to send reports from then on.
3. Hitting "Send" when the "Always send a report" pref is OFF sends the report for the current crash only.
4. Hitting "Don't Send" doesn't send the report for the current crash, and is equivalent to asking for permission for sending a report during subsequent crashes.

Updated

6 years ago
Blocks: 761905
(Assignee)

Comment 1

6 years ago
I'm going to start working on this.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 2

6 years ago
Shortening the summary to make it easier to read.
Summary: As a user, I want to be informed the first time an app crashes on my FirefoxOS phone so that I'm aware that a crash has occurred and I can choose to send a report about it or not. → Show a crash reporter dialog the first time an app crashes

Comment 3

6 years ago
Larissa, just to be clear, this together with bug 801809 means that we show the full dialog twice, once when the OS (Gecko) crashes for the first time and once when an app crashes for the first time (once for all apps), is that the intention? Also, what about browser tab crashes?
(Reporter)

Comment 4

6 years ago
(In reply to Margaret Leibovic [:margaret] from comment #2)
> Shortening the summary to make it easier to read.

Heh. Sorry. Product is trying to do this thing where we write convoluted stories :p
(Reporter)

Comment 5

6 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> Larissa, just to be clear, this together with bug 801809 means that we show
> the full dialog twice, once when the OS (Gecko) crashes for the first time
> and once when an app crashes for the first time (once for all apps), is that
> the intention? 

No. We show this dialog once (ever). The contents of the dialog just varies depending on whether it's a system or an app crash.

> Also, what about browser tab crashes?

Browser tab crashes are a totally different bug. See page 10 of http://people.mozilla.com/~lco/FX_B2G/Release_1_Specs/R1_Tabs_v3.pdf

Comment 6

6 years ago
(In reply to Larissa Co from comment #5)
> No. We show this dialog once (ever). The contents of the dialog just varies
> depending on whether it's a system or an app crash.

OK, that's what I originally thought, I was just confused with you filing two different bugs for that. ;-)

> > Also, what about browser tab crashes?
> 
> Browser tab crashes are a totally different bug. See page 10 of
> http://people.mozilla.com/~lco/FX_B2G/Release_1_Specs/R1_Tabs_v3.pdf

Hmm, that does not take into account sending crash reports for those, which we'd like to do as well. (We'll still need to find out, by talking to the privacy team, if we can send a URL for those tab crashes, I guess we might need a checkbox for that in that tab crash screen.)
(Assignee)

Comment 7

6 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> (In reply to Larissa Co from comment #5)
> > No. We show this dialog once (ever). The contents of the dialog just varies
> > depending on whether it's a system or an app crash.
> 
> OK, that's what I originally thought, I was just confused with you filing
> two different bugs for that. ;-)

Oh, thanks for asking about that, kairo. This is different than what I was thinking, but it makes sense if we're just going to have one "submit crashes" pref to keep track of. I'll see what my patches end up looking like, but these can probably be combined into one bug.

Comment 8

6 years ago
Margaret, I guess we probably need to end up with two prefs, one being a tri-state value for sending always/never/on-asking-every-time (well, even that could be split in two bools if it's easier) and one that tracks if we have ever shown the full dialog (as we need to make sure to only show that on the first crash the user ever sees).
But yes, there shouldn't be any separate tracking of gecko or app crashes, it's just that the full first-time dialog looks a bit differently between those cases.
(Assignee)

Comment 9

6 years ago
I'm working on the crash reporter dialog in bug 801809, but I'll work on the app-specific title in this bug.
Depends on: 801809
Summary: Show a crash reporter dialog the first time an app crashes → Include app name in crash reporter dialog title if the crash was caused by an app
(Assignee)

Comment 10

6 years ago
The PR I made in bug 801925 handles this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801925
You need to log in before you can comment on or make changes to this bug.