Closed Bug 801845 Opened 10 years ago Closed 10 years ago

[keyboard] keyboard aligns to the wrong position after switching orientations, and breaks once dismissed.

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 799644
blocking-basecamp +

People

(Reporter: nhirata, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
## Environment :
Otoro phone, build 2012-10-15 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 0d6d050bc37d3167cc82a1885fd7660456bb0f4e
* "gaia" revision= 589c7f8f7df88766f7a5fa944f6bb05eef04b8c3 
* "releases-mozilla-central" revision= 1ec4bdea9de7c0567810fd09cb55b02304b3186d
* "gonk-misc" revision= 6214475b7cdf4d78c2f51769bad96503aa0fa3bf
  
## Repro :
1. go to the browser app
2. tap in the url field
3. switch from portrait to landscape and back

## Expected :
1. the keyboard aligns to the bottom of the screen

## Actual :
1. the keyboard is near the middle.

## Note :
1. happens in other apps like email as well.
hate to ship like this...
blocking-basecamp: --- → ?
OS: Mac OS X → Gonk
Hardware: x86 → ARM
When you try to type on it after the actual, it dismisses the VKB... it's functionally broken.
Blocking on fully broken functionality in a core operation.
blocking-basecamp: ? → +
Priority: -- → P1
Summary: [keyboard] keyboard aligns to the wrong position after switching orientations → [keyboard] keyboard aligns to the wrong position after switching orientations, and breaks once dismissed.
This feel like a dup of bug 799644 to me. I believe what you see is not the keyboard but a ghost of it. Also I can't reproduce in latest build.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799644
You need to log in before you can comment on or make changes to this bug.