IonMonkey: Handle JSOP_IN

RESOLVED FIXED in Firefox 18

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
mozilla19
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

(Whiteboard: [ion:p2])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Dromaeo's CSSQuery-Dojo test attempts to compile a function but fails for lack on Ion JSOP_IN support. Welp.
Sounds like this could matter for performance, if just to compile the surrounding function.
Whiteboard: [ion:p2]
(Reporter)

Comment 2

6 years ago
Created attachment 672147 [details] [diff] [review]
Implement JSOP_IN using callVM.
Attachment #672147 - Flags: review?
(Reporter)

Updated

6 years ago
Attachment #672147 - Flags: review? → review?(jdemooij)
Comment on attachment 672147 [details] [diff] [review]
Implement JSOP_IN using callVM.

Review of attachment 672147 [details] [diff] [review]:
-----------------------------------------------------------------

Nice. Both TM and JM+TI (bug 664824) have/had a fast path for "int32 in dense array". Can you file a follow-up bug so that we don't forget about it?
Attachment #672147 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/d3a655f609ca
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 672147 [details] [diff] [review]
Implement JSOP_IN using callVM.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 786160
User impact if declined: Significant performance regression on benchmarks
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): Very little, might expose existing JIT bugs by nature of allowing more to JIT.
String or UUID changes made by this patch:
Attachment #672147 - Flags: approval-mozilla-aurora?
Comment on attachment 672147 [details] [diff] [review]
Implement JSOP_IN using callVM.

Approving it on aurora as it has a significant perf impact
Attachment #672147 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/1faef77e84da
status-firefox18: --- → fixed
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.