[Settings] Won't remember the Data Connection status after reboot

VERIFIED FIXED

Status

Firefox OS
Gaia
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: John Shih, Assigned: vingtetun)

Tracking

unspecified
x86_64
Linux
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
## Environment :
Otoro phone, build 2012-10-16
Build info: 
* "gaia" revision= 6a6c070293c6cd404fc7d3d7afece401dd114419
* "gecko" revision= add440caf2f26a55f86e456502689709a9fed143

## Repro :
1. Launch the settings
2. Set the APN setting and turn on the Data Connection
3. See the "3G" shows on the status bar
4. Reboot the device
5. After boot, see the status bar (still can see the "3G" there)
6. Go the settings to check the status of Data Connection 

## Expected:
* See the status is on

## Actual:
* The status is off
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?

Comment 1

5 years ago
I cannot reproduce this issue.  Do you mean the Data Connection in settings is turned off after reboot, but you still can see the 3G connected in status bar?

Comment 2

5 years ago
Related to this I filed a bug to enable data by default. Right now its off by default.
I found this in logcat after launching settings:

10-16 16:02:14.589: E/GeckoConsole(105): [JavaScript Error: "value is not an object" {file: "jar:file:///system/b2g/omni.ja!/components/SettingsManager.js" line: 114}]

Not sure if it's related.
I was able to reproduce this issue on the same nightly build as John Shih
(Reporter)

Comment 5

5 years ago
Shian-Yow: yes, that is exactly what I mean

Updated

5 years ago
Keywords: qawanted
Looks like the Status bar UI is correct, you are still connected there; the bug is that the settings will reset to off when you restart the settings app.

You can reproduce the issue by killing the settings app and launching the app; you will still have mobile network connection and data transfer, the settings app just shows the wrong thing.
## Environment :
Otoro phone, build 2012-10-17
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 0d6d050bc37d3167cc82a1885fd7660456bb0f4e
* "gaia" revision= e3efbd0411218762cf9a62278bf58ee513ff331f 
* "releases-mozilla-aurora" revision= 03b0489737178628de48fa29ba71b2f3cedc3172
* "gonk-misc" revision= 6214475b7cdf4d78c2f51769bad96503aa0fa3bf
Keywords: qawanted

Updated

5 years ago
blocking-basecamp: ? → +
Priority: -- → P2

Comment 8

5 years ago
Marking blocking-basecamp+ because our users will be using the data connection setting regularly and will be confused by this. Marking as a P2 since this doesn't block any immediate testing.

Comment 9

5 years ago
We found the issue only reproducible on some Otoro devices, and it was fixed by a manual factory reset (rm -r /data/local) on problematic device and flashing image again.  It could be the device contains some outdated settings.
Keywords: qawanted
Created attachment 673193 [details] [diff] [review]
Patch

This happens because one of the value of a setting is /null/ and mozSettings tries to have fun with it.
Assignee: nobody → 21
Attachment #673193 - Flags: review?(anygregor)
Attachment #673193 - Flags: review?(anygregor) → review+

Comment 11

5 years ago
This patch works for me.  Are we going to land it?
(Reporter)

Comment 12

5 years ago
I need to test it when this patch is landing
Because I still met this bug with my own build

Updated

5 years ago
Keywords: qawanted
https://hg.mozilla.org/integration/mozilla-inbound/rev/d208c273a705
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Oups. I didn't meant to close it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [checking-needed-aurora]
https://hg.mozilla.org/mozilla-central/rev/d208c273a705

Should this have a test?
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Whiteboard: [checking-needed-aurora]
(Reporter)

Comment 16

5 years ago
It doesn't happen anymore

test with 
2012-10-26
gaia master : 2c50025f7a7ce6f2e653c0e75ef7bd505d823cb8
gecko : c9173078c6a84ed9a423868090cf57f593247f53
Status: RESOLVED → VERIFIED
status-firefox18: --- → fixed
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.