[WiFi] WEP key length should be 5 or 13

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: masashi.honma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

229 bytes, text/html
arthurcc
: review+
fcampo
: review+
Details
(Reporter)

Description

6 years ago
The WEP key length is defined in [1] "11.2.2.1 WEP overview" section.
The section defines 40-bit and 104-bit key. So I made this restriction.

See PR #5702 for patch.

[1] IEEE Std 802.11-2012
This appears to already be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Gaia → Gaia::System
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
> This appears to already be fixed.

No, this is not fixed but my PR was just closed.
I checked it now with lates Gaia and Gecko.
I think this should be fixed.
Status: RESOLVED → UNCONFIRMED
Component: Gaia::System → Gaia::Settings
Resolution: FIXED → ---
(Reporter)

Comment 3

5 years ago
Created attachment 750865 [details]
Pull Request
(Reporter)

Updated

5 years ago
Attachment #750865 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 4

5 years ago
Created attachment 750866 [details]
Pull Request
Attachment #750865 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Attachment #750866 - Attachment mime type: text/plain → text/html
Attachment #750866 - Flags: review?(fernando.campo)
Attachment #750866 - Flags: review?(arthur.chen)
(Reporter)

Comment 5

5 years ago
To check WEP key length is important feature but currently not implemented.

I implemented it for settings and FTE.
Patch looks good to me, but I want to bring people to the conversation, as apparently they were involved on the original discussion on https://github.com/mozilla-b2g/gaia/pull/5702

Personally, I never used WEP, so not sure if the 5 or 13 char restriction would be nice to apply, or a blocker. If that's the case, please set the corresponding flags, as it would speed up the process now that we're focused on tef+ bugs
Flags: needinfo?(kaze)
Flags: needinfo?(21)
I don't know much about WEP key restriction. mrbkap did the original wifi backend so let's see if he knows more.
Flags: needinfo?(21) → needinfo?(mrbkap)
I don’t know much about WEP key restriction either, but though I like the way this patch is written I’m afraid that a strict five-or-thirteen length control would break existing cases and it doesn’t bring such a big UX improvement otherwise.

I’ll rely on Blake’s opinion for this patch.
Flags: needinfo?(kaze)
I'm not sure that I'm much help here either. I *thought* that in addition to hex keys of 5 and 13 characters, some routers (maybe old Apple internet sharing via wifi?) also allowed passphrases of semi-arbitrary lengths, but I can't verify that.
Flags: needinfo?(mrbkap)
(Reporter)

Comment 10

5 years ago
Blake Kaplan,

> hex keys of 5 and 13 characters

Right, I have modified the Pull Request to support HEX key input.
I have tested with ASCII 5, 13 and HEX 10, 26 key.

> semi-arbitrary lengths

Indeed, some STA/AP vendor supports 16 and 29 ASCII characters (32, 58 HEX characters) as a vendor specific functionality.
And I agree exsiting user will use these length.
So, I have modified the Pull Request to support these.

But now we could not use 32 HEX characters even if without this patch.
Because gecko/dom/wifi/WifiWorker.js#isWepHexKey() doesn't support it.
If somebody will need this key length, we should modify isWepHexKey() out of this bug.
Vincent,
Could you provide some inputs here? We are not so sure about the WEP key restriction. Thanks.
Flags: needinfo?(vchang)
I am fine with this restriction. The term WEP by itself refers to either
WEP-40(ASCII 5 and HEX 10) or WEP-104(ASCII 13 or HEX 26) in IEEE 80211 spec.
Flags: needinfo?(vchang)
Comment on attachment 750866 [details]
Pull Request

Masashi, thank you for the patch. Based on the comments above, it looks good to me. r=me.
Attachment #750866 - Flags: review?(arthur.chen) → review+
(Reporter)

Comment 14

5 years ago
Arthur Chen, thanks for your review.

Fernando Campo, is there any comment ?
Comment on attachment 750866 [details]
Pull Request

No comments at all, the code looks good, and you already have r+ from people who knows more than me about WEP, so you're good to go.


Do you have permissions to merge or do you need me to do so?
Attachment #750866 - Flags: review?(fernando.campo) → review+
(Reporter)

Comment 16

5 years ago
Fernando Campo,

> Do you have permissions to merge or do you need me to do so?

No, I don't have permissions to merge.
If you can, merge my patch.
Merged on master https://github.com/mozilla-b2g/gaia/commit/5d5013bd9c51e27fa90b54751e85070d76465c0c

Thanks Masashi!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.