Closed Bug 802400 Opened 12 years ago Closed 12 years ago

Talos Regression trobopan on Android, Oct 11

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Android
defect
Not set
normal

Tracking

(firefox19+ fixed, firefox20 fixed, fennec19+)

RESOLVED FIXED
Firefox 20
Tracking Status
firefox19 + fixed
firefox20 --- fixed
fennec 19+ ---

People

(Reporter: gbrown, Assigned: BenWa)

References

Details

Attachments

(1 file)

From dev-tree-management Digest, Vol 46, Issue 137:

Date: Thu, 11 Oct 2012 20:01:26 -0000
Subject: Talos Regression Robocop Pan Benchmark increase 3.61e+03%
        on        Android 2.2 (Native) Mozilla-Inbound

Regression Robocop Pan Benchmark increase 3.61e+03% on Android 2.2 (Native) Mozilla-Inbound
----------------------------------------------------------------------------------------------
    Previous: avg 21466.093 stddev 5402.627 of 30 runs up to revision 5b26e3ffe80d
    New     : avg 796503.600 stddev 57054.061 of 5 runs since revision c58bfc3f6b48
    Change  : +775037.507 (3.61e+03% / z=143.456)
    Graph   : http://mzl.la/Pqqd8G

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5b26e3ffe80d&tochange=c58bfc3f6b48

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/c58bfc3f6b48
    : Benoit Girard <b56girard@gmail.com> - Bug 798539 - Run the animation timer faster to improve panning smoothness. r=blassey,kats
    : http://bugzilla.mozilla.org/show_bug.cgi?id=798539

Bugs:
  * http://bugzilla.mozilla.org/show_bug.cgi?id=798539 - Jerkiness at the end of panning


:BenWa is already aware of this regression: https://bugzilla.mozilla.org/show_bug.cgi?id=798539#c30
tracking-fennec: --- → ?
Blocks: 798539
tracking-fennec: ? → 19+
Assignee: nobody → bgirard
Attached patch Revert timerSplinter Review
The other changes are still good, we should only restore the timer to backout this patch.
Attachment #672855 - Flags: review?(bugmail.mozilla)
Attachment #672855 - Flags: review?(bugmail.mozilla) → review+
What's happening with this patch?


The regression is now on Aurora:

Message: 3
Date: Tue, 20 Nov 2012 14:02:14 -0000
From: nobody@cruncher.build.mozilla.org
To: dev-tree-management@lists.mozilla.org
Subject: Talos Regression Robocop Pan Benchmark increase 2.45e+03%
        on        Android 2.2 (Native) Mozilla-Aurora
Message-ID:
        <20121120140214.A02EF1042ED@cruncher.srv.releng.scl3.mozilla.com>
Content-Type: text/plain; charset="us-ascii"

Regression Robocop Pan Benchmark increase 2.45e+03% on Android 2.2 (Native) Mozilla-Aurora
---------------------------------------------------------------------------------------------
    Previous: avg 25342.910 stddev 4102.789 of 30 runs up to revision 65a8897d2e7a
    New     : avg 647240.400 stddev 79248.479 of 5 runs since revision b3950b0ad29a
    Change  : +621897.490 (2.45e+03% / z=151.579)
    Graph   : http://mzl.la/Ue9m6Y

Changeset range: http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=65a8897d2e7a&tochange=b3950b0ad29a
Cwiiis: FYI I'm restoring the time so I expect panning to get worse on GN. I think the right fix here is to implement the C++ Async Pan Zoom Control in Fennec. This will also fix the suspected GC pauses.
I forgot to CC Cwiiis. See Comment 4.
https://hg.mozilla.org/mozilla-central/rev/7c10b030d920
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Since this is tracking for 19 it would seem we are looking for a mozilla-aurora nomination here - can someone can go ahead with that?
(In reply to Lukas Blakk [:lsblakk] from comment #7)
> Since this is tracking for 19 it would seem we are looking for a
> mozilla-aurora nomination here - can someone can go ahead with that?

Yes, I wanted to bake on central for a week. Let's uplift!
Comment on attachment 672855 [details] [diff] [review]
Revert timer

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 798539
User impact if declined: Benchmark regression
Testing completed (on m-c, etc.): on m-c for a week
Risk to taking this patch (and alternatives if risky): low, restore timer interval to what it was on beta
String or UUID changes made by this patch: none
Attachment #672855 - Flags: approval-mozilla-aurora?
Attachment #672855 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: