The default bug view has changed. See this FAQ.

Invalidation problem with nested fixed-position elements

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mike Nicholls, Assigned: cwiiis)

Tracking

({regression})

17 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16 unaffected, firefox17+ fixed, firefox18 unaffected, firefox19 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 672140 [details]
invalidation.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121010150351

Steps to reproduce:

Opened the attached testcase in Firefox 17 beta, pressed the button.


Actual results:

Seemingly nothing, until the window is resized or select-all is used, revealing the word "Test".


Expected results:

The word "Test" should immediately appear above the button, as it does in Firefox 16.
(Reporter)

Updated

5 years ago
Attachment #672140 - Attachment mime type: text/plain → text/html

Comment 1

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/ef20925bc2a5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120725002955
Bad:
http://hg.mozilla.org/mozilla-central/rev/75d16b99e8ab
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120725080455
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ef20925bc2a5&tochange=75d16b99e8ab

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/eecd3aa199e6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120724224555
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/79727970b987
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120725000855
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eecd3aa199e6&tochange=79727970b987
Suspected by : Bug 769541



And Fixed in 18.0 and later, but not in 17beta.
(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/b274e8e3479f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928160219
Fixed:
http://hg.mozilla.org/mozilla-central/rev/b62b229a4d41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928161018
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b274e8e3479f&tochange=b62b229a4d41
(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
Blocks: 769541
Status: UNCONFIRMED → NEW
status-firefox16: --- → unaffected
status-firefox18: --- → unaffected
status-firefox19: --- → unaffected
tracking-firefox17: --- → ?
Ever confirmed: true
Keywords: regression

Comment 2

5 years ago
Chris - can you take a look at this for FF17? Looks like DLBI fixed this for FF18.
Assignee: nobody → chrislord.net
status-firefox17: --- → affected
tracking-firefox17: ? → +
(Assignee)

Comment 3

5 years ago
Is this not fixed by bug 786740?

Comment 4

5 years ago
Indeed, I can confirm that bug 786740 fixed this problem.
Fixed range:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=7ab34cfe4869&tochange=e669a7b1ed5e
(Assignee)

Comment 5

5 years ago
Bug 786740 has been pushed to both beta and aurora, so marking this as fixed and dependent.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 786740
Resolution: --- → FIXED

Updated

5 years ago
status-firefox17: affected → fixed
You need to log in before you can comment on or make changes to this bug.