Last Comment Bug 802568 - PSL uplift for Firefox 17
: PSL uplift for Firefox 17
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 06:23 PDT by Gervase Markham [:gerv]
Modified: 2012-11-10 08:07 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed


Attachments
Patch v.1 for mozilla-aurora (5.41 KB, patch)
2012-11-09 05:48 PST, Gervase Markham [:gerv]
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Patch v.1 for mozilla-beta (9.06 KB, patch)
2012-11-09 05:48 PST, Gervase Markham [:gerv]
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2012-10-17 06:23:05 PDT
Firefox 17 is an ESR, and due for release on November 20th. We should uplift all the PSL changes which are on mozilla-central that it doesn't already have, which is quite a few. For consistency, we'll also need patches for the aurora channel.

All of these changes have baked on trunk, and they are config/policy changes rather than code changes. So they should be safe to take (and we have taken them many times in the past, even on the release channel).

We should work through the current batch of open requests, get those done, wait a few days, and then upload patches to this bug with all the necessary changes.

Gerv
Comment 1 Gervase Markham [:gerv] 2012-11-09 05:37:24 PST
Marking tracking-firefox-17?. 

The reason we'd want to take this for 17 is that it rolls in a number of policy changes which have been made since 17 branched from mozilla-central. We take changes to the IDN whitelist and the PSL on stable release branches anyway, but there has been quite a bit of activity recently and so it seems wiser and simpler to get them uplifted in time for the initial release of the ESR.

The next step is for me to produce a rollup patch, which I will do shortly. 

Gerv
Comment 2 Gervase Markham [:gerv] 2012-11-09 05:48:15 PST
Created attachment 680059 [details] [diff] [review]
Patch v.1 for mozilla-aurora

This patch updates the PSL and IDN whitelist on Aurora to be the same as that of mozilla-central.

Gerv
Comment 3 Gervase Markham [:gerv] 2012-11-09 05:48:54 PST
Created attachment 680060 [details] [diff] [review]
Patch v.1 for mozilla-beta

This patch updates the PSL and IDN whitelist on Beta to be the same as that of mozilla-central.

Gerv
Comment 4 Gervase Markham [:gerv] 2012-11-09 05:50:59 PST
Comment on attachment 680059 [details] [diff] [review]
Patch v.1 for mozilla-aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A

User impact if declined: IDN not displaying correctly in .com, .net., .name, .gt, and domain display incorrect/cookie security parameters incorrect for various domains (see patch)

Testing completed (on m-c, etc.): A couple of policy changes are recent (finalized in time for ESR) but others have been baking for weeks.

Risk to taking this patch (and alternatives if risky): Near-zero.

String or UUID changes made by this patch: None.

Gerv
Comment 5 Gervase Markham [:gerv] 2012-11-09 05:51:13 PST
Comment on attachment 680060 [details] [diff] [review]
Patch v.1 for mozilla-beta

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A

User impact if declined: IDN not displaying correctly in .com, .net., .name, .gt, and domain display incorrect/cookie security parameters incorrect for various domains (see patch)

Testing completed (on m-c, etc.): A couple of policy changes are recent (finalized in time for ESR) but others have been baking for weeks.

Risk to taking this patch (and alternatives if risky): Near-zero.

String or UUID changes made by this patch: None.

Gerv
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-09 13:59:14 PST
Comment on attachment 680059 [details] [diff] [review]
Patch v.1 for mozilla-aurora

Approving for Aurora, we'll get bake time there.  Gerv is there any reason this waited until just before the last Beta to get tracked?  It was filed 3 weeks ago and it would have been nice to know about it sooner.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-09 14:08:57 PST
For Beta - we are going to build with our last 17 beta on Monday so please land this asap.
Comment 8 Gervase Markham [:gerv] 2012-11-10 08:07:25 PST
(In reply to Lukas Blakk [:lsblakk] from comment #6)
> Approving for Aurora, we'll get bake time there.  Gerv is there any reason
> this waited until just before the last Beta to get tracked?  It was filed 3
> weeks ago and it would have been nice to know about it sooner.

I'm afraid the reason is that I suck :-| Sorry.

Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/e5aa14969f18
Beta:   https://hg.mozilla.org/releases/mozilla-beta/rev/c32e71b351b2

Gerv

Note You need to log in before you can comment on or make changes to this bug.