Last Comment Bug 802616 - don't use software floating point math on ARMv6
: don't use software floating point math on ARMv6
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla19
Assigned To: Brad Lassey [:blassey] (use needinfo?)
: Kevin Brosnan [:kbrosnan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:50 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2014-01-10 10:39 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed
17+


Attachments
patch (987 bytes, patch)
2012-10-17 07:50 PDT, Brad Lassey [:blassey] (use needinfo?)
mh+mozilla: review-
Details | Diff | Review
patch (1.02 KB, patch)
2012-10-17 08:41 PDT, Brad Lassey [:blassey] (use needinfo?)
mh+mozilla: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-10-17 07:50:38 PDT
Created attachment 672305 [details] [diff] [review]
patch

this is OMG slowing us down, I think we just need to make floating point hardware a min system requirement
Comment 1 Mike Hommey [:glandium] 2012-10-17 07:53:54 PDT
Comment on attachment 672305 [details] [diff] [review]
patch

Please make the change in the mozconfigs.
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-10-17 07:56:04 PDT
(In reply to Mike Hommey [:glandium] from comment #1)
> Comment on attachment 672305 [details] [diff] [review]
> patch
> 
> Please make the change in the mozconfigs.

I don't want to. I want this to be the default so that developers will be building the same thing we are shipping
Comment 3 Mike Hommey [:glandium] 2012-10-17 07:59:01 PDT
(In reply to Brad Lassey [:blassey] from comment #2)
> (In reply to Mike Hommey [:glandium] from comment #1)
> > Comment on attachment 672305 [details] [diff] [review]
> > patch
> > 
> > Please make the change in the mozconfigs.
> 
> I don't want to. I want this to be the default so that developers will be
> building the same thing we are shipping

The change in build/autoconf/arch.m4 impacts more than developers. Developers already have to add something to do armv6 build, i don't see why it would be a problem for them to add something more.
Comment 4 Mike Hommey [:glandium] 2012-10-17 07:59:59 PDT
Comment on attachment 672305 [details] [diff] [review]
patch

Review of attachment 672305 [details] [diff] [review]:
-----------------------------------------------------------------

Make it at least limited to Android.
Comment 5 Justin Wood (:Callek) 2012-10-17 08:14:39 PDT
Without looking at how high up in the configure we need/want this, my suspicion is a change in http://mxr.mozilla.org/comm-central/source/mozilla/mobile/android/confvars.sh would do what brad and glandium want, without being intrusive
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-10-17 08:41:55 PDT
Created attachment 672330 [details] [diff] [review]
patch
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-10-17 15:24:15 PDT
Comment on attachment 672330 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: for some reason (we will investigate) soft float math is killing us on region operations, which is making display list building very slow, which makes panning very slow. Not taking this will make panning slower than we want it to be.
Testing completed (on m-c, etc.): just landed on m-i, should probably get a couple nightlies before uplift
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: 



https://hg.mozilla.org/integration/mozilla-inbound/rev/c4119fd2fb37
Comment 8 Ed Morley [:emorley] 2012-10-18 10:36:36 PDT
https://hg.mozilla.org/mozilla-central/rev/c4119fd2fb37
Comment 9 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-18 10:52:46 PDT
Triage drive-by, will wait for a couple of nightlies.
Comment 11 Tracy Walker [:tracy] 2014-01-10 10:39:09 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.