crash in mozilla::FileBlockCache::Read @ libstagefright.so@0xf... on devices with Mali-400 MP GPU running ICS

NEW
Unassigned

Status

()

Firefox for Android
Graphics, Panning and Zooming
--
critical
5 years ago
10 months ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, steps-wanted})

17 Branch
Firefox 19
ARM
Android
crash, steps-wanted
Points:
---

Firefox Tracking Flags

(firefox17+ fixed, firefox18+ fixed)

Details

(Whiteboard: [native-crash], [swdecoder], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
With combined signatures, it's #5 top crasher in 17.0b1.
It might be related to bug 787319.

Signature 	libstagefright.so@0xf6f0a More Reports Search
UUID	42869678-d7de-4e64-9e22-93d332121017
Date Processed	2012-10-17 14:27:21
Uptime	799
Last Crash	13.9 hours before submission
Install Age	4.1 days since version was first installed.
Install Time	2012-10-13 10:55:22
Product	FennecAndroid
Version	17.0
Build ID	20121010211745
Release Channel	beta
OS	Linux
OS Version	0.0.0 Linux 3.0.8+ #46 PREEMPT Wed Mar 28 14:15:15 CST 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0xdeadbaad
App Notes 	
AdapterDescription: 'ARM -- Mali-400 MP -- OpenGL ES 2.0 -- Model: T01A, Product: crane_evb, Manufacturer: unknown, Hardware: sun4i'
EGL? EGL+ GL Context? GL Context+ GL Layers? GL Layers+ WebGL? WebGL+ 
unknown T01A
softwinners/crane_evb/crane-evb:4.0.3/IML74K/20120328:eng/test-keys
EMCheckCompatibility	True
Adapter Vendor ID	ARM
Adapter Device ID	Mali-400 MP
Device	unknown T01A
Android API Version	15 (REL)
Android CPU ABI	armeabi-v7a

Frame 	Module 	Signature 	Source
0 	libc.so 	libc.so@0x17660 	
1 	libstagefright.so 	libstagefright.so@0xf6f0a 	
2 	libstagefright.so 	libstagefright.so@0xf6f0a 	
3 	libstagefright.so 	libstagefright.so@0xf6f0a 	
4 	libcutils.so 	libcutils.so@0x3f3f 	
5 	libxul.so 	array_slice 	js/src/jsarray.cpp:2955
6 		@0x69536d1e 	
7 	OMXCodec (deleted) 	OMXCodec @0x26971 	
8 	dalvik-heap (deleted) 	dalvik-heap @0xbafa944 	
9 	dalvik-heap (deleted) 	dalvik-heap @0x5b8a25d 	
10 	pkg.apk 	pkg.apk@0x46f544 	
11 	dalvik-heap (deleted) 	dalvik-heap @0x4b1af42 	
12 	libnspr4.so 	PR_Unlock 	nsprpub/pr/src/pthreads/ptsynch.c:205
13 	libxul.so 	mozilla::FileBlockCache::Read 	Mutex.h:83 

More reports at:
https://crash-stats.mozilla.com/query/query?product=FennecAndroid&query_search=signature&query_type=contains&query=libstagefright.so%400xf&do_query=1

Comment 2

5 years ago
Assigning to Chris Double to help take a look here for FF17.
Assignee: nobody → chris.double

Updated

5 years ago
Keywords: needURLs, qawanted

Comment 3

5 years ago
Chris - please email us if you don't have access to a Mali-400 MP GPU device to investigate and need it.

Updated

5 years ago
tracking-firefox17: ? → +

Comment 5

5 years ago
I appear to be crashreport-challenged, how does one find an url for testing from a crash report? Can someone provide a SFW url here?

Alex, I don't have have a Mali-400 GPU device and will probably need one to investigate. Do you have a brand name for a device that has this GPU? Once I have an URL to test on other devices I'll confirm.
(Reporter)

Comment 6

5 years ago
Created attachment 672693 [details]
List of devices for libstagefright.so@0xf... crash signatures

(In reply to Chris Double (:doublec) from comment #5)
> Do you have a brand name for a device that has this GPU?
See the attachment.
The 0xdeadbaad SIGSEGV is indicative of bionic's abort() function. This is probably a case of Stagefright's CHECK() macro, which aborts on failure.

Comment 8

5 years ago
Is there an example URL that demonstrates the crash?
Email sent with URLs. They are all adult in nature thus not included in this report.

Comment 10

5 years ago
I've tested these URLs on a Galaxy S 2 (GT-I9100) running ICS 4.0.3 and couldn't reproduce the crash.
LGE LG-P500 	6
ZTE Skate
Sony Tablet S 	8
LGE LG-P500 	16
Unknown BC1003 	8
Unknown MID 	5
Unknown P300(Funbook) 	21
Unknown AK-MINI-PC-001 	4
Unknown MID 	16
Unknown M1001 	13
Unknown GT-7205S 	12
Unknown i-mobile i-note WiFi 	8
Unknown GT-7200 	5
(In reply to Naoki Hirata :nhirata from comment #11)
> LGE LG-P500 	6
> ZTE Skate
> Sony Tablet S 	8
> LGE LG-P500 	16
> Unknown BC1003 	8
> Unknown MID 	5
> Unknown P300(Funbook) 	21
> Unknown AK-MINI-PC-001 	4
> Unknown MID 	16
> Unknown M1001 	13
> Unknown GT-7205S 	12
> Unknown i-mobile i-note WiFi 	8
> Unknown GT-7200 	5

Let's try reproducing now that we've identified these affected devices. Adding steps-wanted.
Keywords: steps-wanted
Let's try with the Optimus One (LGE LG-P500).
QA Contact: kbrosnan
LGE LG-P500 is a ARMv6 phone. The only way it is running ICS is if it was rooted and running a custom rom.
(In reply to Kevin Brosnan [:kbrosnan] from comment #14)
> LGE LG-P500 is a ARMv6 phone. The only way it is running ICS is if it was
> rooted and running a custom rom.

Let's get an order going for a Sony Tablet S in that case. It does run ICS.
(Reporter)

Updated

5 years ago
OS: Linux → Android
Drive-by triage comment:

QA seeking out this device for purchase
(In reply to Aaron Train [:aaronmt] from comment #16)
> Drive-by triage comment:
> 
> QA seeking out this device for purchase

ordered.
Assuming this is a hw decoder problem given the GPU comment.

The plan is to land Bug 806369 (create a blacklist) to deal with this blocker issue here for Firefox 17.  The root cause fix will addressed after Firefox 17.
Depends on: 806369
Whiteboard: [native-crash] → [native-crash], [hwdecoder]
Removing needURLs since they have been emailed according to Comment 9.
Keywords: needURLs
(In reply to Maire Reavy [:mreavy] from comment #18)
> Assuming this is a hw decoder problem given the GPU comment.
> 
> The plan is to land Bug 806369 (create a blacklist) to deal with this
> blocker issue here for Firefox 17.  The root cause fix will addressed after
> Firefox 17.


Since we're using the blacklist for 17, I'm marking 'wontfix' and bumping tracking on 18 so this stays on our radar for the root issue.
status-firefox17: --- → wontfix
tracking-firefox18: --- → +
(Reporter)

Comment 21

5 years ago
Because of the StageFright blacklisting on ICS except for Samsung devices, there are no crashes in 17.0b5 and after 18.0a2/20121108.
The underlying issue is not fixed though.
status-firefox17: wontfix → fixed
(Reporter)

Comment 22

5 years ago
I thinks it's a SW decoder issue that the blocklist handles.
Whiteboard: [native-crash], [hwdecoder] → [native-crash], [swdecoder]

Comment 23

5 years ago
Should this be untracked for FF18 given that it no longer crashes due to the blocklist? The underlying issue won't be fixed for FF18 if a fix is required by 19/11.
(Reporter)

Comment 24

5 years ago
Fixed by bug 806369.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox18: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We want this bug open so that we can fix the actual issue.
Status: REOPENED → NEW
(Reporter)

Updated

5 years ago
Keywords: topcrash

Updated

5 years ago
Keywords: qawanted

Comment 26

4 years ago
(In reply to Tony Chung [:tchung] from comment #17)
> (In reply to Aaron Train [:aaronmt] from comment #16)
> > Drive-by triage comment:
> > 
> > QA seeking out this device for purchase
> 
> ordered.

Did the device arrive? If so can QA confirm if the bug exists if they disable the blocklist?
Looks like the Sony Tablet S we received has a nVidia GPU.

Comment 28

3 years ago
Is this still happening?
Occasionally. Probably not a priority unless STR appear.

https://crash-stats.mozilla.com/search/?signature=~libstagefright.so%400xf&product=FennecAndroid&adapter_device_id=mali&_facets=adapter_device_id&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform

Updated

2 years ago
Assignee: cajbir.bugzilla → nobody

Comment 30

2 years ago
Need Help debugging software device?

I have a device with a product. model = software evb 13 with product.device= crane-evb.  I would like to know the vendor ID for that is to use it for debugging windows USB and or linux or ubuntu? How do I general Debug this device.  What drivers do I need?
You need to log in before you can comment on or make changes to this bug.