strokeText and fillText bug with shadow and translate

VERIFIED FIXED in Firefox 18

Status

()

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: kcleung88, Assigned: ajones)

Tracking

({regression})

18 Branch
mozilla19
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox18+ verified, firefox19+ verified)

Details

Attachments

(4 attachments, 2 obsolete attachments)

Reporter

Description

7 years ago
Posted file test.html
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121016042009

Steps to reproduce:

Using strokeText/fillText in canvas, with shadow and a translate of the position.



Actual results:

Only half (upper part) of the text "ABCDEFG" shown.

Tested in FF 18, window xp.

Comment 1

7 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/3d9424eb6eb4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120901193714
Bad:
http://hg.mozilla.org/mozilla-central/rev/6c66c3997381
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120902185812
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3d9424eb6eb4&tochange=6c66c3997381


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/476d122c82a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120902155712
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6c66c3997381
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120902160711
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=476d122c82a6&tochange=6c66c3997381

Regressed by: Bug 781731
Blocks: 781731
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Version: 13 Branch → 18 Branch

Updated

7 years ago
Attachment #672348 - Attachment mime type: text/plain → text/html
Assignee: nobody → ajones
Try run for 93b1400dc685 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=93b1400dc685
Results (out of 97 total builds):
    exception: 3
    success: 72
    warnings: 17
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-93b1400dc685
Try run for 4307bd191edf is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4307bd191edf
Results (out of 97 total builds):
    exception: 2
    success: 83
    warnings: 7
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-4307bd191edf
Try run for 4307bd191edf is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4307bd191edf
Results (out of 98 total builds):
    exception: 2
    success: 84
    warnings: 7
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-4307bd191edf
Try run for 4307bd191edf is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=4307bd191edf
Results (out of 100 total builds):
    exception: 2
    success: 86
    warnings: 7
    failure: 5
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ajones@mozilla.com-4307bd191edf
Comment on attachment 674477 [details] [diff] [review]
Part 2: Apply transform to text bounds v2

Review of attachment 674477 [details] [diff] [review]:
-----------------------------------------------------------------

Nice find.
Attachment #674477 - Flags: review?(bas) → review+
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/1d7fc5c44ee2
https://hg.mozilla.org/mozilla-central/rev/278e17fa10e7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to :Ms2ger from comment #11)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/1d7fc5c44ee2
> https://hg.mozilla.org/integration/mozilla-inbound/rev/278e17fa10e7

Please nominate for aurora-uplifts once we comfortable with testing/bake-time on m-c.Thanks !
Comment on attachment 674477 [details] [diff] [review]
Part 2: Apply transform to text bounds v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 781731
User impact if declined: Text shadow truncated when transforms applied
Testing completed (on m-c, etc.): on m-c. local testing.
Risk to taking this patch (and alternatives if risky): Low risk and could only affect text shadow because the bounds only used for shadow.
String or UUID changes made by this patch: None.
Attachment #674477 - Flags: approval-mozilla-aurora?
Attachment #674477 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Reporter

Comment 16

7 years ago
Reporter

Updated

7 years ago
Attachment #677750 - Attachment mime type: text/plain → text/html
Reporter

Comment 17

7 years ago
The text still get truncated even in the first attachment test.html with lower shadowBlur value. i.e.

c.shadowBlur=5;
....
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
If so, please file a new bug.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Depends on: 815648
Verified fixed using the testcase and based on comment 18.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0b4
Aurora 19.0a2 (2012-12-18)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.