Increase the number of times Firefox opens before we prompt for Feedback

VERIFIED FIXED in Firefox 17

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Tyler, Assigned: mfinkle)

Tracking

16 Branch
Firefox 19
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 verified, firefox18 verified, firefox19 verified)

Details

(Whiteboard: [SUMO])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Quite a few users are complaining we don't give them enough time to use the product before we ask them for feedback. We can edit http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/BrowserApp.java#89 to change the times we do this. I'm thinking that increasing from 10 to 15 should give users more time for real world use of the product before we prompt.
Created attachment 672663 [details] [diff] [review]
patch

Bumping the delay from 10 to 15 feels safe enough.
Assignee: nobody → mark.finkle
Attachment #672663 - Flags: review?(margaret.leibovic)

Updated

5 years ago
Attachment #672663 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 672663 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: lots of feedback
Testing completed (on m-c, etc.): none yet
Risk to taking this patch (and alternatives if risky): super simple and low risk
String or UUID changes made by this patch: none
Attachment #672663 - Flags: approval-mozilla-beta?
Attachment #672663 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/81f8d4719fd6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Attachment #672663 - Flags: approval-mozilla-beta?
Attachment #672663 - Flags: approval-mozilla-beta+
Attachment #672663 - Flags: approval-mozilla-aurora?
Attachment #672663 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/b868ebaa08fb
https://hg.mozilla.org/releases/mozilla-beta/rev/f1dadfa9d441
status-firefox17: --- → fixed
status-firefox18: --- → fixed
status-firefox19: --- → fixed

Comment 6

5 years ago
After clearing the profile I minimized and opened the application 15 times and the about:feedback opens in new tab.

Build: Firefox for Android 19.0a1 (2012-10-30), Firefox for Android 18.0a2 (2012-10-30), Firefox for Android 17 (2012-10-24), 
Device: Samsung Galaxy Nexus
OS: Android 4.1.2
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-firefox17: fixed → verified
status-firefox18: fixed → verified
status-firefox19: fixed → verified
You need to log in before you can comment on or make changes to this bug.