Last Comment Bug 802703 - [OS X] add LSApplicationCategoryType to the info.plist
: [OS X] add LSApplicationCategoryType to the info.plist
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: unspecified
: x86 Mac OS X
: -- enhancement (vote)
: Firefox 19
Assigned To: Kohei Yoshino [:kohei]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:41 PDT by Kohei Yoshino [:kohei]
Modified: 2012-10-19 01:01 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (459 bytes, patch)
2012-10-17 11:24 PDT, Kohei Yoshino [:kohei]
smichaud: review+
Details | Diff | Review
patch for checkin (1006 bytes, patch)
2012-10-18 07:36 PDT, Markus Stange [:mstange]
no flags Details | Diff | Review

Description Kohei Yoshino [:kohei] 2012-10-17 10:41:32 PDT
+++ This bug was initially created as a clone of Bug #714716 +++

I couldn't find the related bug for Firefox.
Just add the following 2 lines to Info.plist:

<key>LSApplicationCategoryType</key>
<string>public.app-category.productivity</string>
Comment 2 Steven Michaud [:smichaud] (Retired) 2012-10-17 13:30:59 PDT
Comment on attachment 672411 [details] [diff] [review]
patch

Looks fine to me.

I'm not sure I understand the point:  An app's "category" seems to be a Mac App Store thing (http://hints.macworld.com/article.php?story=20111017134102735).

But it seems harmless.
Comment 3 Markus Stange [:mstange] 2012-10-17 13:42:54 PDT
(In reply to Steven Michaud from comment #2)
> I'm not sure I understand the point:

Bug 714716 has more information and a screenshot.
Comment 4 Steven Michaud [:smichaud] (Retired) 2012-10-17 13:56:13 PDT
Oh, OK.  See particularly bug 714716 comment #0.

Interestingly, it seems that /Applications and /Applications/Utilities are the only directories that can be sorted by "Application Category" (at least on OS X 10.7.5, where I tested).  But that's a sensible way to sort those directories.
Comment 5 Markus Stange [:mstange] 2012-10-18 07:36:41 PDT
Created attachment 672786 [details] [diff] [review]
patch for checkin
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-10-18 18:40:57 PDT
https://hg.mozilla.org/mozilla-central/rev/50083503d2e0
Comment 8 Kohei Yoshino [:kohei] 2012-10-19 01:01:02 PDT
Bug 802704 for Thunderbird. Both belongs in the Productivity category.

Note You need to log in before you can comment on or make changes to this bug.