MobileConnection doesn't QI to nsIObserver

RESOLVED FIXED in Firefox 18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: bent.mozilla, Assigned: mounir)

Tracking

Trunk
mozilla19
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed)

Details

Attachments

(1 attachment)

Seeing a bunch of QI assertions on B2G shutdown, looks like MobileConnection doesn't QI to nsIObserver.
Posted patch PatchSplinter Review
I guess that one-liner should do.
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Attachment #672729 - Flags: review?(bent.mozilla)
Attachment #672729 - Flags: review?(bent.mozilla) → review+
Comment on attachment 672729 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 729173
User impact if declined: broken or unexpected behaviour
Risk to taking this patch (and alternatives if risky): unless we had code magically working because of that breakage, none
String or UUID changes made by this patch: none
Attachment #672729 - Flags: approval-mozilla-aurora?
Forgot to say, this patch has to land on aurora for B2G (and it's a B2G-only feature).
Comment on attachment 672729 [details] [diff] [review]
Patch

b2g-only feature, approving for Aurora.
Attachment #672729 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/2030c47a8e69
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.