Closed Bug 802828 Opened 12 years ago Closed 12 years ago

Retina resolution not updated when monitor DPI changes

Categories

(Firefox :: Untriaged, defect)

18 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 794038

People

(Reporter: chris, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121017042010

Steps to reproduce:

I normally use my Retina Macbook Pro hooked up to a (non-retina, obviously) monitor.

Sometimes I unhook it, take it downstairs, and work with it on the couch. Later I reverse this and take it back to the monitor.


Actual results:

Firefox should detect the DPI of the monitor it is being displayed on (in this case, the active monitor changes because I unplug the existing active one and open the clamshell).

Instead, the DPI that was detected when Firefox started up on the monitor it was on at that time, is kept in effect. Depending on which way I'm travelling between monitors, this has one of two effects:

a) if I'm moving onto a retina monitor, the Firefox window renders the existing content in the bottom-left quarter, with displayed garbage in the other three quarters
b) moving off the retina monitor, I see only a part of the previously rendered page, at 4x the size it should be.


Expected results:

Should have re-rendered using the new active monitor DPI.
Let me know if screenshots would assist
Blocks: osx-hidpi
See bug 794038. This was a known limitation of the initial HiDPI support (from bug 674373), and should be better in current Nightly builds (Firefox 19).
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.