Last Comment Bug 802945 - Remove aType parameter from AddonUpdateChecker.checkForUpdates and UpdateParser
: Remove aType parameter from AddonUpdateChecker.checkForUpdates and UpdateParser
Status: RESOLVED FIXED
[good first bug][mentor=bmcbride@mozi...
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla19
Assigned To: Eduard Neculaesi (:eduardn)
:
Mentors:
Depends on: 782118
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 21:39 PDT by Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
Modified: 2012-10-25 12:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
First patch (15.98 KB, patch)
2012-10-24 08:20 PDT, Eduard Neculaesi (:eduardn)
bmcbride: review+
Details | Diff | Review

Description Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-10-17 21:39:06 PDT
Bug 782118 deprecated differentiating add-on types in update manifests. Since then, it's no longer necessary to pass in the add-on type to AddonUpdateChecker.checkForUpdates and UpdateParser - so we should remove that parameter.

These functions are defined in:
https://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/AddonUpdateChecker.jsm

And used here:
https://mxr.mozilla.org/mozilla-central/search?string=AddonUpdateChecker.checkForUpdates
Comment 1 Eduard Neculaesi (:eduardn) 2012-10-22 08:53:44 PDT
I would like to work on this bug!
Comment 2 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-10-22 19:08:16 PDT
Great! I've assigned the bug to you.

If you haven't got a copy of the code and built Firefox yet, have a read through:
https://developer.mozilla.org/en-US/docs/Simple_Firefox_build

And more generally:
https://developer.mozilla.org/en-US/docs/Developer_Guide
Comment 3 Eduard Neculaesi (:eduardn) 2012-10-24 08:20:03 PDT
Created attachment 674667 [details] [diff] [review]
First patch
Comment 4 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-10-24 21:44:24 PDT
Comment on attachment 674667 [details] [diff] [review]
First patch

Review of attachment 674667 [details] [diff] [review]:
-----------------------------------------------------------------

This is perfect - awesome job :)

Will check this into the tree for you soon.
Comment 5 Eduard Neculaesi (:eduardn) 2012-10-24 23:58:49 PDT
Great, thanks!
Comment 6 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-10-25 04:55:26 PDT
Landed on the fx-team branch, which should get merged into mozilla-central within a day.

https://hg.mozilla.org/integration/fx-team/rev/9dbdbab1e38d
Comment 7 Tim Taubert [:ttaubert] 2012-10-25 12:28:10 PDT
https://hg.mozilla.org/mozilla-central/rev/9dbdbab1e38d

Note You need to log in before you can comment on or make changes to this bug.