Closed Bug 802975 Opened 9 years ago Closed 9 years ago

address bar changes to english (url) keyboard after first letter

Categories

(Firefox for Android Graveyard :: Keyboards and IME, defect, P2)

17 Branch
Other
Android
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: noamtm, Assigned: jchen)

References

Details

User Agent: Mozilla/5.0 (Android; Mobile; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121010211745

Steps to reproduce:

Go to address bar, switch to hebrew keyboard layout, try to search google.


Actual results:

After typing the first letter the keyboard layout changes to English (for typing urls).


Expected results:

keep my selected layout, so i can search.
(In reply to Noam Tamim from comment #0)
> After typing the first letter the keyboard layout changes to English (for
> typing urls).
Hi, I understood from you that you have used Anysoft Keyboard. Have you tried using the stock Android keyboard or another keyboard? Currently I am unable to reproduce this issue on my own device. 

Does the problem you are facing affects only typing on the address bar or HTML input elements as well? Please also supply some information about your device including your model, Android version, and your ROM in case you use custom ROM on your device.

Thanks for your help.
(In reply to Tomer Cohen :tomer from comment #1)

Unfortunately my device (Samsung GS2 with ICS from Samsung) doesn't have the stock Android keyboard. It also doesn't have Samsung's hebrew keyboard layout. I just tried with Hacker's Keyboard, and the bug does NOT reproduce.
It does consistently reproduce with Anysoft Keyboard, which is very popular. It doesn't happen with other browsers (Chrome and the stock ICS browser), so I assume it IS a Firefox issue.

It seems to only affect the address bar.
I can confirm that this issue affect my device as well (Galaxy S2, Cyanogenmod 9, ICS 404) using the AnySoft Keyboard but not Hacker's keyboard. 

Tested with Firefox 16 (release), Firefox Beta 17 and Aurora 18.

AnySoft Keyboard eye-candy v76-20120814 https://play.google.com/store/apps/details?id=com.menny.android.anysoftkeyboard


Steps to reproduce:
a. Install AnySoft Keyboard and configure it to Hebrew/English layouts.
b. Launch Firefox. 
c. Tap the address bar.
d. Switch to the Hebrew layout.
e. Tap an Hebrew letter. 

Current result:
Keyboard layout switches to English. If switching layout back to Hebrew it stays as expected until moving the focus from the browser address bar. 


I've notified the application developer about this issue on https://code.google.com/p/softkeyboard/issues/detail?id=1022.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reproducible for me as well. I'll take a look.
Assignee: nobody → nchen
Priority: -- → P2
This goes back to bug 710843.

When the awesomebar first shows, it has the "go" action.
Once the user enters a character, we reset the keyboard to the "search" action.
But AnyKeyboard has the behavior that when it resets, it switches back to the Latin keyboard.

I think this is something worth fixing in AnyKeyboard
Also filed issue on GitHub, https://github.com/AnySoftKeyboard/AnySoftKeyboard/issues/62

A workaround is to disable "QWERTY Latin keyboard" and enable "QWERTY keyboard with symbols" in the AnySoftKeyboard settings.
Resolving as wontfix since it's a bug in the keyboard. See comment #6 for a workaround.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.