[AccessFu] Typed keys no longer echoed back by TalkBak in web content

VERIFIED FIXED in Firefox 18

Status

()

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: MarcoZ, Assigned: eeejay)

Tracking

({regression})

Trunk
mozilla19
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

Regression. Used to work, despite other editing problems like not being able to re-read character by character what one typed. But keyboard echo used to work in 17.

STR:
1. Open a web page that has an input type text field. Notice that while typing the URL in the awesome bar, characters are echoed back.
2. Touch, then double-tap to focus that input.
3. Start typing.

Expected: Each character should be heard twice, once when touching it, once after lifting the finger to actually enter it.
Actual: Only the touch part is heard. When lifting the finger, the entered character is no longer echoed back.

Impact: Sometimes, the finger may slide to the adjacent character right before lifting, and another character is entered. It is important to be able to hear what one actually typed.
Attachment #673391 - Flags: review?(dbolter)
Comment on attachment 673391 [details] [diff] [review]
Fixed android textChanged presenter.

Review of attachment 673391 [details] [diff] [review]:
-----------------------------------------------------------------

Ouch. Sorry I let that through.
Attachment #673391 - Flags: review?(dbolter) → review+
https://hg.mozilla.org/mozilla-central/rev/43eca3085ddc
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Verified fixed in the 2012-10-20 nightly build.
Status: RESOLVED → VERIFIED
Comment on attachment 673391 [details] [diff] [review]
Fixed android textChanged presenter.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): B2G reorg to account for out-of-process web apps
User impact if declined: Users will not hear typed characters in inputs on the web through TalkBack, not be able to control what they typed.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None known.
Attachment #673391 - Flags: approval-mozilla-aurora?
Comment on attachment 673391 [details] [diff] [review]
Fixed android textChanged presenter.

Approving for aurora considering its a regression & the user impact for our accessibility users
Attachment #673391 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.