No sound in Firefox on Linux (HTML5 video and audio)

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: fzserra, Unassigned)

Tracking

16 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121012055127

Steps to reproduce:

I tried to play audio in Firefox in several ways: through HTML5 video, through HTML5 audio, through sound notifications (like the ones in DownThemAll). I use Arch Linux x86, the stock Firefox build from the Arch Linux PKGDB and ALSA for sound output. 


Actual results:

No sound was ever played. The Gnash (GNU replacement for Flash) plugin does play sound but any other way to play audio inside Firefox fails.


Expected results:

It should have played sounds. Audio used to play back when I had Pulseaudio installed but stopped playing since I removed it (back then I had Firefox 15, even after updating and re-installing the problem persists). It seems to me as if Firefox is trying to use Pulse for output but I haven't sound any setting or config to edit to tell it to use ALSA instead.

Comment 2

7 years ago
[Loic: Setting the needinfo flag is welcome for such questions.]
Flags: needinfo?(fzserra)
(Reporter)

Comment 3

7 years ago
@Loic: I did but nothing changed. I also tried starting from a fresh installation and that did nothing as well. 

I should add that no other application has ever given me audio problems on my machine aside from FF and that HTML5 audio and video work fine on other browsers such as Midori.
Flags: needinfo?(fzserra)
(Reporter)

Comment 4

7 years ago
Update: I tried reinstalling Pulseaudio (yuck!) and ran the server but nothing really changed, Firefox still doesn't play any sound.
(Reporter)

Comment 5

7 years ago
Update II: I tried Firefox-beta-bin (which would be Firefox 17.0b2-1), Firefox-aurora (Firefox 18.0a2-latest) and manually compiled Iceweasel (Firefox 16.0.1-1), all the them with a fresh .mozilla folder. No one of them was able to play sound, they all acted the same regardless of version, profile or being binary or compiled from source by myself.

I don't know what to do anymore, I think I've done all I could as a user. I hope the devs will look into the issue because it could affect other Linux users as well.

Comment 6

7 years ago
Ok I have exactly the same problem I tried evrything i could too
I hope this bug will be fixed,

Comment 7

6 years ago
Does any of you still have this issue?

Have you tried with a build from Mozilla?  If the "stock" build is not an official Mozilla build, it is likely to be different with respect to sound.
Flags: needinfo?
I'm having the same problem. Flash works but any audio generated by Firefox itself doesn't work. From looking at a different bug(812900) I think it has to do with Firefox outputting it's audio in float_le format which my card doesn't support.
Flags: needinfo?

Comment 9

6 years ago
Robert: Using a build from Mozilla? Which desktop environment?
Flags: needinfo?(gooberslot)
Nevermind, I fixed it my changing some alsa settings.
Flags: needinfo?(gooberslot)

Comment 11

6 years ago
[Restoring previous needinfo state]
I am seeing (but not hearing!) this too with Nightly on Fedora 20. Flash audio works. HTML5 audio does not. I am using pulseaudio.

Oh, wait! Ok, finally figured this out. It looks like it's using the HDMI output. If I go to Multimedia/PulseAudio Volume Control (which runs pavucontrol) while a video is playing and change the output device (it's sticky), it works again.

Which implies that my problem (wrong default output device?) may be different from the original reporter's, but I'm leaving this here in case it helps anyone else.

Updated

5 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core

Comment 13

4 years ago
(In reply to Robert Killingsworth from comment #10)
> Nevermind, I fixed it my changing some alsa settings.

What settings?

In my case, pure ALSA and no PulseAudio, audio seems to be working for Flash and anything else _except_ Firefox Hello, which I understand uses HTML5.  I heard rumor that HTML5 uses a different ALSA device.
Actually, I never did fix it I just thought I did. I think I changed the setting to use type plug instead of the raw hardware device and that got it somewhat working but Firefox would sometimes start eating a huge amount of cpu time and I'd have to close it down to get it working again. I eventually gave up and just started using the inferior built-in sound on my motherboard.  Even then I had to make sure to add period_size=1024 and buffer_size=8192 to my asound.conf to get it to work. Now it mostly works but I get a loud pop sometimes when I start playing a sound. Sigh. I wish the Firefox developers spent half the time they spend on the Windows version on the Linux version.

Comment 15

4 years ago
On the off chance anyone else wanders to this report with the Firefox Hello issue, one solution (which worked for me) is to remove the user's .asoundrc file or simplify it to something of this form:

defaults.pcm.card 0
defaults.ctl.card 0

I have seen other examples with different numbers--depending on which sound device should be used.  Thanks for your patience with my brief hijacking of this thread.  We now return you to your regularly scheduled programming.  :-)
Component: Audio/Video → Audio/Video: Playback

Comment 16

3 years ago
I have no Youtube sound on HDMI output with Firefox 46.0.1 in openSUSE 13.2 (without pulseaudio installed), which counter to comment 15 requires 

	pcm.!default "hdmi:1,0"

and nothing else in /etc/asound.conf in order to get system sounds, VLC sounds and SMplayer sounds from HDMI output. HDMI output HTML5 sound is fine on Youtube from latest package management system's Firefox in same machine booted instead to openSUSE 13.1, openSUSE 42.1 or Debian Stretch. /proc/asound/cards contains:

  0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                       HDA ATI HDMI at 0xfeb64000 irq 37
  1 [Generic        ]: HDA-Intel - HD-Audio Generic
                       HD-Audio Generic at 0xfeb60000 irq 16

Comment 17

3 years ago
Reinstalling previously removed pulseaudio, and fully configuring all ouputs with pavucontrol, enabled sound from HTML5.

Comment 18

3 years ago
Closing as per last comment - seems to be a local / distribution-level issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.