Test failure "Only one autocompleted result is underlined - '0' should equal '1'" in testAwesomeBar tests

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: AndreeaMatei, Assigned: AndreeaMatei)

Tracking

unspecified

Firefox Tracking Flags

(firefox16 fixed, firefox17 fixed, firefox18 fixed, firefox19 fixed, firefox-esr10 fixed)

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
This is happening with some Awesome bar tests which use pages that are also bookmarked by default. The autocomplete results are getting switched at some point and causes the test to fail.
We need to replace the bookmarked pages from those tests in order to have only history entries in autocomplete results.
(Assignee)

Updated

5 years ago
Assignee: nobody → andreea.matei
Whiteboard: [mozmill-test-failure]
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Blocks: 792394
Priority: -- → P1
(Assignee)

Comment 1

5 years ago
Created attachment 672780 [details] [diff] [review]
patch v1

Replacing bookmarked pages with simple ones in the only tests using them and underlined: testCheckItemHighligh.js and testSwitchToTab.js
Attachment #672780 - Flags: review?(hskupin)
Attachment #672780 - Flags: review?(dave.hunt)
Comment on attachment 672780 [details] [diff] [review]
patch v1

Review of attachment 672780 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine so far. But what about e.g. visibleItemsMax which also uses this test page and searches for entries by typing 'll' in the location bar. This will also cause a conflict with the default bookmark, or? Probably we should figure that out on another bug and simply clear all bookmarks first too for the awesomebar tests.
Attachment #672780 - Flags: review?(hskupin)
Attachment #672780 - Flags: review?(dave.hunt)
Attachment #672780 - Flags: review+
http://hg.mozilla.org/qa/mozmill-tests/rev/8ee93b29b45a (default)

If that hasn't been caused any regression I will land it on the other branches after the testruns tomorrow.
status-firefox-esr10: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → affected
status-firefox19: --- → fixed
(Assignee)

Comment 4

5 years ago
The patch applies cleanly for Aurora too.
The other branches will be taking care of as soon as we land testSwitchToTab.js there too. I'll upload patch on bug 779127 right away.
(In reply to Andreea Matei [:AndreeaMatei] from comment #4)
> The patch applies cleanly for Aurora too.

http://hg.mozilla.org/qa/mozmill-tests/rev/33df8e0a7f21 (aurora)

> The other branches will be taking care of as soon as we land
> testSwitchToTab.js there too. I'll upload patch on bug 779127 right away.

Why? As said before both are independent. If one of the tests is not available on the branch because we do not backport new tests, please update the patch accordingly.
status-firefox18: affected → fixed
(Assignee)

Comment 6

5 years ago
Created attachment 674159 [details] [diff] [review]
[beta, esr10, release] patch v1

This applies for beta, esr10 and release, replacing the community page on testCheckItemHighlight.js
Attachment #674159 - Flags: review?(hskupin)
Attachment #674159 - Flags: review?(dave.hunt)
Comment on attachment 674159 [details] [diff] [review]
[beta, esr10, release] patch v1

Review of attachment 674159 [details] [diff] [review]:
-----------------------------------------------------------------

Don't forget to include the reviewers in your commit message. I fixed this before pushing/transplanting.

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/458efa393bc2 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/99a09b8eb4d4 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/93bfa2f49007 (esr10)
Attachment #674159 - Flags: review?(hskupin)
Attachment #674159 - Flags: review?(dave.hunt)
Attachment #674159 - Flags: review+
Attachment #674159 - Flags: checkin+

Updated

5 years ago
status-firefox-esr10: affected → fixed
status-firefox16: affected → fixed
status-firefox17: affected → fixed
All done here. Marking it as resolved fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.