google.com/green has broken sniffing for the prefix to use with "transform", ends up trying to set "trueTransform"

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: karlcow)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(firefox16-, firefox17-, firefox18-, firefox19-)

Details

(Whiteboard: [webkitjs] [country-all] , URL)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/0507d387617c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0 ID:20121010144125

This problem happens since Bug 745523 landing.
 
Steps to reproduce:
1. Open http://www.google.com/green/storyofsend/desktop/#/it-starts-with-send

Actual results:
Sound is played back as expected.
However, no graphics is not drawn.
(Reporter)

Updated

5 years ago
Summary: Graphics is not drawn → Graphics is not drawn due to unprefix css3 transforms on certain site
Looks like the usual "Assume things are prefixed" thing.  For example:

            function a() {
                var a = b("transform"),
                    c = a + "Perspective" in document.documentElement.style || n;
                return a ? {
                    vendor: a,
                    Kb: c
                } : n
            }
            function b(a) {
                var c = document.createElement("div"),
                    b = ["Khtml", "Ms", "O", "Moz", "Webkit"],
                    d = b.length;
                if (a in c.style) return k;
                for (a = a.replace(/^[a-z]/, function (a) {
                    return a.toUpperCase()
                }); d--;) if (b[d] + a in c.style) return b[d];
                return n
            }

So b("transform") will return k.  k is the JS value true.  That will then test for "truePerspective" in document.documentElement.style, end up with false, and set "vendor" to true and "Kb" to n.  n is false.

Then this will go through and do things like set document.documentElement.className to "vendortrue" and worse yet get to this.wb which does:

        this.wb = function (b) {
            if (a.N) {
                var c = a.N.vendor + "Transform",
                    d = O.ta(b.Sa, b.Ta);
                b.a.style[c] = d
            } else {
                b.a.style.top = b.Ta + "px";
                b.a.style.left = b.Sa + "px"
            }
            b.$ = b.Sa;
            b.aa = b.Ta
        };

which will try to set "trueTransform" on b.a.style, which will of course do absolutely nothing.

Looks pretty similar to the script we saw in bug 790915, actually.
Summary: Graphics is not drawn due to unprefix css3 transforms on certain site → Graphics is not drawn
Summary: Graphics is not drawn → google.com/green has broken sniffing for the prefix to use with "transform", ends up trying to set "trueTransform"
Dbaron, if this is pretty similar to what we say in bug 790915 and I'm reading your comment https://bugzilla.mozilla.org/show_bug.cgi?id=790915#c16 correctly, then it seems that we actually don't have to track this and that this becomes a tech evangelism issue - is that correct or am I missing something?
Assignee: nobody → dbaron
I mailed the Google folks about this, by the way.
Assignee: dbaron → english-us
Component: Style System (CSS) → English US
Product: Core → Tech Evangelism
Version: 16 Branch → unspecified

Updated

5 years ago
tracking-firefox16: ? → -
tracking-firefox17: ? → -
tracking-firefox18: ? → -
tracking-firefox19: ? → -
This isn't a critical website regression so we'll untrack, people will have to do outreach/evangelism on this but we won't block a release on it.
So what I know so far is that both this site and the site in bug 790915 were apparently done by the same company: B-Reel.  http://www.b-reel.com/digital/projects/story-of-send/ for the Google end of this.

So what we should probably do is contact them and find out what other things they've done, since I bet everything they've done will break this way.  :(

I can't tell whom to contact from their contact page.  Lukas, do you think you can get hold of someone who knows how to talk to outfits like this and get them to do it?
Johnny, do you know how we can get someone who can deal with this to look at it?
(Assignee)

Comment 7

3 years ago
Confirmation that there is still no graphics there. Moving this to Desktop.
Assignee: english-us → kdubost
Status: NEW → ASSIGNED
Component: English US → Desktop
Whiteboard: [webkitjs] [country-all]
Now renders like in Chrome for me - was it fixed?
Flags: needinfo?(kdubost)
(Assignee)

Comment 9

3 years ago
With Firefox 32 on Desktop 
Going to http://www.google.com/green/storyofsend/desktop/#/it-starts-with-send
Redirect to http://www.google.com/green/#/it-starts-with-send

I don't hear any sounds, but all graphics seem to be displayed as planned.
Maybe the Web site changed since the initial design.

We don't have screenshots.
But if I go to 
http://web.archive.org/web/20130325090336/http://www.google.com/green/storyofsend/desktop/

We can note that the site was different. This section doesn't exist anymore. 
Let's close as INVALID.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kdubost)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.