don't block UI thread on memory pressure

RESOLVED FIXED in mozilla21

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: blassey, Assigned: snorp)

Tracking

(Blocks 1 bug, {meta})

unspecified
mozilla21
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

No description provided.
Blocks: 803149
No longer depends on: 803149
Blocks: 803155
For future reference: blocking the UI thread on gecko while handling memory pressure was done on purpose, in bug 747445.
Comment on attachment 707703 [details] [diff] [review]
Don't wait on Gecko for non-emergent memory reduction events

Review of attachment 707703 [details] [diff] [review]:
-----------------------------------------------------------------

s/emergent/emergency/ in the commit message. I think emergent means something else..
Attachment #707703 - Flags: review?(bugmail.mozilla) → review+
No longer blocks: 822505
Duplicate of this bug: 822505
Assignee: bugmail.mozilla → snorp
https://hg.mozilla.org/mozilla-central/rev/b211a11259a7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.