Closed Bug 803165 Opened 7 years ago Closed 7 years ago

[OS.File] No OS.File for Gonk

Categories

(Toolkit :: OS.File, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- wontfix
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: ochameau, Assigned: Yoric)

References

Details

Attachments

(1 file, 3 obsolete files)

When adding:
  Components.utils.import("resource://gre/modules/osfile.jsm")
On top of:
  http://mxr.mozilla.org/mozilla-central/source/dom/apps/src/Webapps.jsm
I got the following exception:
[JavaScript Error: "NS_ERROR_XPC_BAD_IID: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]" file: "resource://gre/modules/osfile/osfile_shared_allthreads.jsm" line: 31}]

When running on the device. (I haven't tried on desktop)
It sounds like nsIOSFileConstantsService.{idl, xpt} is not installed on Gonk.

What file controls the list of idl/xpt installed on Gonk?
Assignee: nobody → dteller
ochameau, any chance you could check if this patch solves the issue for you?
Attachment #672839 - Attachment is obsolete: true
Attachment #678283 - Flags: feedback?(poirot.alex)
Fix the original exception but it's being replaced by a new one:
JavaScript Error: "OS.Constants is undefined" {file: "resource://gre/modules/osfile/osfile_async_front.jsm" line: 36}
Ok, as I feared, the binary component is not installed in Gonk. I will need to find how to remedy this.
David the patch you attached did not match the description. Did you mean one that addressed comment 4?
Summary: Exception on Cu.import osfile.jsm → [OS.File] No OS.File for Gonk
Attachment #678283 - Flags: feedback?(poirot.alex)
Sorry, wrong patch. Any idea how I can test this or who could review this?
Attachment #678283 - Attachment is obsolete: true
Attachment #694378 - Flags: review?
Comment on attachment 694378 [details] [diff] [review]
Adding dom_system.xpt to the installer, v2

Roll the rice. Also, the commit message is wrong in just about every way possible :)
Attachment #694378 - Flags: review? → review?(ted)
Comment on attachment 694378 [details] [diff] [review]
Adding dom_system.xpt to the installer, v2

Review of attachment 694378 [details] [diff] [review]:
-----------------------------------------------------------------

This is fine, but this only fixes Firefox for Android, which is not Gonk. Did you actually mean Gonk (which is the underpinnings of B2G), or are you just confused?
Attachment #694378 - Flags: review?(ted) → review+
Sorry, wrong patch.
Attachment #694378 - Attachment is obsolete: true
Attachment #694436 - Flags: review?(ted)
Attachment #694436 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/1ec805274a72
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Blocks: 829934
Comment on attachment 694436 [details] [diff] [review]
Adding dom_system.xpt to the installer, v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): blocks a blocker
User impact if declined: we need that for a better user experience with app updates
Testing completed: nothing neede
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #694436 - Flags: approval-mozilla-b2g18?
Attachment #694436 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
You need to log in before you can comment on or make changes to this bug.