[AccessFu] No window is passed to Presenter.viewportChanged()

RESOLVED FIXED in Firefox 18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

Trunk
mozilla19
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

No description provided.
Comment on attachment 672993 [details] [diff] [review]
Provide window to viewportChanged in presenters

Review of attachment 672993 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/src/jsat/EventManager.jsm
@@ -81,3 @@
>          this.present(
>            function(p) {
> -            return p.viewportChanged();;

Heh. I was confused by this yesterday.
Oops.. I thought the last comment was an r+, just noticed it is still not.
Comment on attachment 672993 [details] [diff] [review]
Provide window to viewportChanged in presenters

Review of attachment 672993 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Eitan Isaacson [:eeejay] from comment #4)
> Oops.. I thought the last comment was an r+, just noticed it is still not.

I guess it is ok. Why is the variable still called "window"?
Attachment #672993 - Flags: review?(dbolter) → review+
https://hg.mozilla.org/mozilla-central/rev/114ea5032eb0
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 672993 [details] [diff] [review]
Provide window to viewportChanged in presenters

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 791400
User impact if declined: Rectangle does not get updated once the page starts scrolling. Indication of accessibility focus broken.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #672993 - Flags: approval-mozilla-aurora?
Attachment #672993 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.