Last Comment Bug 803465 - Iframe shouldn't override a sub document role
: Iframe shouldn't override a sub document role
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: alexander :surkov
:
Mentors:
Depends on:
Blocks: aria
  Show dependency treegraph
 
Reported: 2012-10-19 00:31 PDT by alexander :surkov
Modified: 2012-10-22 19:07 PDT (History)
1 user (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.49 KB, patch)
2012-10-19 00:31 PDT, alexander :surkov
dbolter: review+
Details | Diff | Splinter Review

Description alexander :surkov 2012-10-19 00:31:51 PDT
Created attachment 673123 [details] [diff] [review]
patch

We were asked to not propagate the role from iframe to sub document. Rich said:

"The problem is that when you have an IFrame, the role attribute applied to the IFrame is applied to the child document contained within the IFrame. This creates two problems:

1. If the author applies a navigation landmark on the IFrame Firefox copies it over the role of the child document. We have a situation in our cloud based office suite where Firefox is doing this.
2. If the author has actually set a role on the child document contained within the IFrame and the author had applied a role to it (such as role="application") it will be overridden.

This is very problematic as it breaks interoperability."

"We discussed it today and we think it is a huge mistake to be overriding the roles a author sets in web content in the browser when mapping to the accessibility API."

The behavior was introduced in bug 419416. Example and document link that could clarify the need to this behavior don't work anymore. I think it's reasonable to follow Rich's suggestion.
Comment 1 David Bolter [:davidb] 2012-10-19 06:19:35 PDT
Comment on attachment 673123 [details] [diff] [review]
patch

Review of attachment 673123 [details] [diff] [review]:
-----------------------------------------------------------------

Aaron won't like this (I recall discussion from years ago) but I think this is the right thing to do as per comment 0.
Comment 2 alexander :surkov 2012-10-19 06:25:23 PDT
(In reply to David Bolter [:davidb] from comment #1)

> Aaron won't like this (I recall discussion from years ago) but I think this
> is the right thing to do as per comment 0.

I'd love to hear another point of view. Personally I don't have opinion this since I don't have valid usecases. We were asked to change it and arguments were reasonable so I meet them half-way.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-10-22 19:07:43 PDT
https://hg.mozilla.org/mozilla-central/rev/c127ae4496a3

Note You need to log in before you can comment on or make changes to this bug.