Closed Bug 803475 Opened 7 years ago Closed 7 years ago

[b2g-bluetooth] Failed to transfer audio back to bluetooth headset while in a phone call

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: gyeh, Assigned: gyeh)

References

Details

Attachments

(1 file, 3 obsolete files)

When we connect with a bluetooth headset, Sco will be created while there's a phone call, and user can initiate audio transfer to close Sco socket. At this time, the audio route should be set back to headphone.

However, during the phone call, if user want to make the audio transfer again (which means set audio route to back Sco), we don't have listen socket and we can't accomplish the request.

Repro:
- Connect to a bluetooth headset
- Make a phone call
- Initiate audio transfer and set audio route to headphone (some bluetooth devices support this feature)
- Initiate audio transfer and set audio route back to bluetooth headset

Expected Behaviour:
- Create a Sco socket
- Should hear sounds from bluetooth headset

Actual Behaviour:
- Doesn't create a Sco socket and failed to make the audio transfer
Depends on: 804436
No longer depends on: 804436
Assignee: nobody → gyeh
Attachment #674578 - Flags: review?(kyle)
Comment on attachment 674578 [details] [diff] [review]
Patch 1(v1): Add Listen() in BluetoothScoManager

Review of attachment 674578 [details] [diff] [review]:
-----------------------------------------------------------------

Failing for same reasons as Bug 804436.

::: dom/bluetooth/linux/BluetoothDBusService.cpp
@@ +723,5 @@
>    {
> +    BluetoothHfpManager* hfp = BluetoothHfpManager::Get();
> +    if (hfp) {
> +      hfp->Listen();
> +    }

nit: Might want to warn on these failing?
Attachment #674578 - Flags: review?(kyle) → review-
Fixed as comments and also based on Bug 804436 patch 0.
Attachment #674578 - Attachment is obsolete: true
Attachment #674978 - Flags: review?(kyle)
Comment on attachment 674978 [details] [diff] [review]
Patch 1(v2): Add Listen() in BluetoothScoManager

Review of attachment 674978 [details] [diff] [review]:
-----------------------------------------------------------------

I think you uploaded the wrong patch? This looks like the Hfp patch.
Attachment #674978 - Flags: review?(kyle) → review-
Oops! Please check the new one (v3), thanks.
Attachment #674978 - Attachment is obsolete: true
Attachment #675390 - Flags: review?(kyle)
Attachment #675390 - Flags: review?(kyle) → review+
https://hg.mozilla.org/mozilla-central/rev/1cd611b97178
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.