Closed Bug 803535 Opened 7 years ago Closed 7 years ago

WebRTC crash [@mozilla::MediaEngineDefault::EnumerateAudioDevices]

Categories

(Core :: WebRTC, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla19

People

(Reporter: posidron, Assigned: jesup)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Attachments

(3 files, 2 obsolete files)

Attached file testcase
Assertion failure: i < Length() (invalid array index), at ../../dist/include/nsTArray.h:537

Not sure if this is a duplicate of:

https://bugzilla.mozilla.org/show_bug.cgi?id=803052
Sorry,

Not sure if this is a duplicate of: 

https://bugzilla.mozilla.org/show_bug.cgi?id=780790
Attached file callstack
That crashreport is a different bug
This *may* be a mirror to the lack of locking in MediaEngineWebRTC (and probably is, since it modifies the lists - though it never removes them, so that's odd.  Still, we should avoid two instances of fake streams colliding as well, so I'll add the equivalent mutex and we can re-test.
Attachment #673396 - Flags: review?(anant)
Attachment #673396 - Attachment is obsolete: true
Attachment #673396 - Flags: review?(anant)
Attachment #673398 - Flags: review?(anant)
Comment on attachment 673398 [details] [diff] [review]
Add mutex for MediaEngineDefault access

Review of attachment 673398 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #673398 - Flags: review?(anant) → review+
Attachment #673398 - Attachment is obsolete: true
Mutex is probably good, but the real bug is a cut-and-paste of audio vs video in a loop
Attachment #673403 - Flags: review?(anant)
Comment on attachment 673403 [details] [diff] [review]
Add mutex for MediaEngineDefault access

Review of attachment 673403 [details] [diff] [review]:
-----------------------------------------------------------------

Wow, that was subtle! Nice catch.
Attachment #673403 - Flags: review?(anant) → review+
https://hg.mozilla.org/mozilla-central/rev/e8a93741f3e6

Should this have a crashtest?
Assignee: nobody → rjesup
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Keywords: verifyme
(In reply to Jason Smith [:jsmith] from comment #3)
> https://crash-stats.mozilla.com/report/bp-d5ab0ba9-2e56-4928-b321-
> 4e6fe2121019

Jason, please file as a new bug if it still happens.
Crash Signature: [@ zzz_AsmCodeRange_Begin]
Verification of this is blocked on the implementation in bug 791330. This test case still crashes due to that bug.
Depends on: 791330
Keywords: verifyme
Whiteboard: [qa verification blocked]
Keywords: verifyme
Whiteboard: [qa verification blocked]
Verified on 10/23 trunk with the test case attached.
Keywords: verifyme
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.