Font rendering in canvas is much worse than Safari

RESOLVED DUPLICATE of bug 780362

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 780362
6 years ago
6 years ago

People

(Reporter: bz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 673256 [details]
Testcase

Trying the simple attached testcase, the text looks much worse than it does in Safari... or in the content area.

Part of that last is grayscale vs subpixel antialiasing and lack of hidpi rendering, but Safari has those going on too, and still its text is much more readable.
It looks to me like Safari does HiDPI (but grayscale) text in canvas; I think the primary difference here is simply that our canvas is not yet HiDPI-enabled at all. (Bug 780362)
Hmm.  I thought (per discussion in bug 780362) canvas couldn't default to hi-dpi...
Ah, the discussion was just confused.

So it's possible that this is just bug 780362, then.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780362
You need to log in before you can comment on or make changes to this bug.