Closed Bug 803638 Opened 7 years ago Closed 7 years ago

[AccessFu] Print more useful exception error outputs

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

Details

Attachments

(1 file)

We do a lot of Logger.error(exception) calls. Instead we should have a Logger.logException, which would provide a file, line number and optionally a stack.
Attachment #673341 - Flags: review?(dbolter)
Comment on attachment 673341 [details] [diff] [review]
introduce logException

Review of attachment 673341 [details] [diff] [review]:
-----------------------------------------------------------------

Fine with me.
Attachment #673341 - Flags: review?(dbolter) → review+
https://hg.mozilla.org/mozilla-central/rev/b2f24b1dc786
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 673341 [details] [diff] [review]
introduce logException

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial implementation of AccessFu logging.
User impact if declined: None, but if users send in exceptions, this would help us more easily identify potential problem areas.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #673341 - Flags: approval-mozilla-aurora?
Comment on attachment 673341 [details] [diff] [review]
introduce logException

Approving for aurora as its low risk and logging related
Attachment #673341 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.