Closed Bug 803661 Opened 7 years ago Closed 7 years ago

Can't save from the view source window

Categories

(Toolkit :: View Source, defect)

18 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox18 + verified
firefox19 --- verified

People

(Reporter: neil, Assigned: neil)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

As of bug 795065, attempting to save from the view source window throws a JavaScript ReferenceError: gDocument is not defined.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #673379 - Flags: review?(josh)
Attachment #673379 - Flags: review?(josh) → review+
https://hg.mozilla.org/mozilla-central/rev/561d6a3c4d7b

Any way to test this?
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Keywords: regression
Version: unspecified → 18 Branch
Comment on attachment 673379 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 795065
User impact if declined: Minor, need to save file from browser (assuming source window was opened from the browser; Error Console, DOM Inspector and other addons might also be capable of opening source windows).
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low, code path is only used for saving from the view source window.
String or UUID changes made by this patch: None
Attachment #673379 - Flags: approval-mozilla-aurora?
(In reply to neil@parkwaycc.co.uk from comment #4)
> Comment on attachment 673379 [details] [diff] [review]
> Proposed patch
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): 795065
> User impact if declined: Minor, need to save file from browser (assuming
> source window was opened from the browser; Error Console, DOM Inspector and
> other addons might also be capable of opening source windows).
> Testing completed (on m-c, etc.): 
> Risk to taking this patch (and alternatives if risky): Low, code path is
> only used for saving from the view source window.
> String or UUID changes made by this patch: None

Neil , How about "Testing completed (on m-c, etc.): " ? Was there any specific testing done to verify this ?
Adding qawanted to do a quick check on this ..
Keywords: qawanted
QA Contact: jbecerra
I spot checked this by opening several types of pages, html, scripts, pdfs, and then opening the view source window, selecting all and saving as. Then opening the saved documents and making sure they opened.
Keywords: qawanted
Attachment #673379 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to neil@parkwaycc.co.uk from comment #0)
> As of bug 795065, attempting to save from the view source window throws a
> JavaScript ReferenceError: gDocument is not defined.

Can you attach the link you got this issue please ? Because I did different kinds of exploratory on FF 18b6 and Nightly (19/10/2012) but they didn't help a lot without knowing the root cause.
I confirm the fix is verified on FF 20b5:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130313170052)

Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0(20130313170052)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0(20130313170052)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.